Tls: oversized record received with length 29795 Error

When trying to user sudo snap install or if I try snap find.
I am running Ubuntu 17.04
I have removed snapd and then re-installed with no fix.
I am behind a corp proxy that does NOT require login.
I have verified the correct proxy in /etc/environment to be correct. I even tried a secondary proxy that had no change.

Has been going on for days.

What else am I missing?

$ sudo snap install rocketchat-server
error: cannot install "rocketchat-server": Get
       tls: oversized record received with length 29795

Thanks, Nick


What happens if you access that URL outside of snapd? Actually, that one is rather cumbersome to copy-paste, so try this instead:

curl -s -H X-Ubuntu-Series:16

Doesn’t seem to do anything. It just goes back to linux prompt.
Also attempted with sudo but same thing.

Hmm… and this?

curl -s

Same as last time…nothing

Ah! OK, let’s try again:

curl -D- -s

Again, Nothing. Sounds like I broke something

That last one should be printing something. Hmm.

How about

printenv | grep -i ^http

It lists my http and https proxy URLs
These are both the PAC addresses. I have also attempted with the straight addresses with :8080

I’ve never seen PACs work in linux (but then again I’ve had the fortune of not having to worry about them in ages). Could you try again with the “direct” ones? Use the printenv to check your shell picked up the change before trying curl again.

I updated /etc/enrivonment to :8080 and ran command again. - Showed PAC
I checked /etc/apt/apt.conf it has the :8080 URL
I ran export http_proxy and export https_proxy - grep command showed the :8080 as it should
Your curl command started to print like it should.

curl -D- -s
HTTP/1.1 200 Connection established

HTTP/1.1 200 OK
Content-Type: application/json; charset=utf-8
Date: Fri, 25 Aug 2017 17:51:53 GMT
ETag: W/"e-+3Pmmp/QERKiJq3DueGVYg"
Server: nginx/1.10.2
set-cookie: sails.sid=s%3AC2l_Ak3kNWhp6amQvmDJaEhA0L4tHdjp.QpeuLC3Vd2aPtCeQ8iMWu253Opxer5n0qxx%2Fnmivzs4; Path=/; HttpOnly
Vary: Accept-Encoding
Content-Length: 14
Connection: keep-alive


But my sudo snap install rocketchat-server still get the same error.

OK! with the :8080 addresses in /etc/environment, systemctl restart snapd should let it pick up the change, and you should be in business!

That fixed it. Everything is back up and running to me.