The tig classic snap just gets stuck


#1

Hello!

I tried to make a snap for tig, which is an ncurses interface for git. Because it requires access to the git global configuration, I made the snap classic. However, when I run the tig command, it just gets stuck. Nothing appears on syslog either. Any idea what could be wrong here?

Here is the snapcraft.yaml:

To reproduce:

git clone https://github.com/elopio/tig
cd tig
git checkout snapcraft
snapcraft
sudo snap install *.snap --dangerous --classig
tig

The projects I've failed to snap
#2

Oh, look at this. It finally failed with:

prctl(PR_SET_SECCOMP, SECCOMP_MODE_FILTER, ...) failed: Cannot allocate memory
aborting: Cannot allocate memory

#3

I’m experiencing the same problem with my gnome-calendar and gnome-contacts classic snaps. No idea how to debug this.


#4

Software being stuck is pretty hard to debug remotely without more details. There’s most likely something failing inside the software itself, that we cannot tell because it’s not saying anything. It’s also most probably not related to the issue @elopio reported above.

I suggest opening a new topic and providing under it as much detail as you can about the problem, so others can try to help identify what’s the actual issue or at least providing some more ideas for how to debug.


#5

Thanks to @zyga we figured out this is an exec loop in snapd caused by a snapcraft bug. It can be worked around be specifying the command as bin/gox instead of gox.


#6

Thanks @kenvandine and @zyga. Adding bin to the command, it started working. I’ve sent it upstream:


#7

Can you have a look at https://github.com/jonas/tig/pull/721

My impression is that the snap needs to include git as well.