Stuck on "Preparing to push" [Solved]

Worked previously using ubuntu 16. Upgraded to ubuntu 18.04 and using docker to build the snap. logging in seems fine.

docker run -v $PWD:/src:Z -w /src yakshaveinc/snapcraft:core18 snapcraft
echo $SNAPCRAFT_LOGIN_FILE | base64 --decode --ignore-garbage > snapcraft.login
snapcraft login --with snapcraft.login
snapcraft push $SNAPFILE

Gets stuck here with no obvious error:

Snapped wickrprobeta_5.41.3_amd64.snap

Login successful. You now have these capabilities:

snaps:       No restriction
channels:    No restriction
permissions: ['package_access', 'package_manage', 'package_push', 'package_register', 'package_release', 'package_update']
expires:     2020-01-30T20:21:31.620750

Preparing to push 'wickrprobeta_5.41.3_amd64.snap'.

hi @spomp, have you tried looking at Debugging building snaps or Troubleshoot snap building.

actually the issue turned out to be network related. the upload just took about an hour. There was some service interruption reported on snap today and the way our log files worked I was not seeing the percentage complete slowly tick along. Eventually the upload worked so this issue will probably resolve itself once the service issues are resolved with snap store. thanks for taking a look though