Store unable to accept: contains external symlinks to sudo.service

I was able to successfully build and upload my snap to the store for the last 6 months, but since some days I’m getting the following error while uploading to the store:

Error while processing…
The store was unable to accept this snap.

  • package contains external symlinks: lib/systemd/system/sudo.service

I understand that this means I’m using an external symlink in my snap linking to lib/.... But why did this error suddenly appear now? Tried to revert snapcraft without any success. In any case, I probably need to change this symlink to the right location. I already tried the following, but still get the error:

bind: $SNAP/lib/systemd/system

I’m not even sure which part is using the sudo.service. How can I fix this?

just remove the link in a prime entry … you should be able to find out which part pus it in place by looking at the parts/<partname>/install/ dirs …

Thanks, it was pulled in by the catkin-tools plugin. I removed it with

- -lib/systemd/system/sudo.service

However, I’m wondering if this can lead to problems since I assume this symlink is created for some reason?!

in a strict snap it would go nowhere anyway since that dir on teh host is not accessible by the snap …