Stopping and starting snap daemons from another snap

I have a flutter app running on a NUC with core20. The app requires a web browser to provide authentication. When required I currently set wpe-webkit-mir-kiosk url to equal the required authentication url and then start the browser daemon. when the flutter app is notified of authentication I call to stop the browser daemon.

I have it working in devmode but no matter what I do I can not get it to work in strict mode. This is a snap for our brand store.

I have snapd-control interface connected and I have tried using
snapctl start wpe-webkit-mir-kiosk to no avail.

I have tried using
http POST snapd:///v2/wpe-webkit-mir-kiosk action=enable however this does not work either.

Am I missing something fundamental or is this just not possible in strict mode?

Any input to this would be most appreciated.

Thank-you in advance.

If your snap has snapd-control then it will have access to /run/snapd.socket. You can do HTTP operations using it.

You may want to reference this:

Hope that helps!

A specific example from the link:

sudo curl -sS --unix-socket /run/snapd.socket http://localhost/v2/snaps/hello -X POST -d '{"action": "install", "channel": "edge"}' 

you are missing /apps/ there …

see the POST /v2/apps section at: