Steam Remote Play Together with Snaps

Snaps don’t work with Steam Remote Play Together

Does anyone know a workaround or why this is?

Steam Remote Play Together let’s you stream a game or any program to one or more people and gives them the ability to use their controller or keyboard on your system to enable you to play local multiplayer games over the internet.

Right click any game in Steam that has Remote Play Together enabled
Set Launch Options
/snap/bin/anysnapprogram # %command%

This let’s you launch a Snap from Steam and start a Remote Play Together session, but the window doesn’t get streamed to the other people. Deb programs work fine with this method.

My guess is Steam doesn’t see that the Snap’s window is in focus as Steam says the remote session is paused. Which is what happens when you un-focus a game that does work.

I tried to run a snap installed with --devmode and that doesn’t work either

Hey, Rick.

Could you provide us an example of a specific snap are you trying? So I could try to reproduce it here on my Steam?


This happens on every snap I have tried.

I mostly want to use this for RetroArch, but I have also tested - Chromium, Glimpse-Editor, Inkscape, OBS-Studio, OhMyGiraffe, and Strawberry

I created a bug report on launchpad here