Solved: Unable to use ptrace in confinement

No matter what I do to change this within the snapd interfaces, I’m unable to get ptrace working in some meaningful way. It looks like the Feral Interactive titles use ptrace internally, and this is breaking them
within full confinement (with an ongoing local interface to provide steam-support)

type=SECCOMP msg=audit(1514056566.032:4966): auid=1000 uid=1000 gid=1000 ses=2 pid=29967 comm="HitmanPro" exe=2F686F6D652F7566656531646561642F537465616D4C6962726172792F737465616D617070732F636F6D6D6F6E2F4869746D616EE284A22F62696E2F4869746D616E50726F sig=31 arch=c000003e syscall=101 compat=0 ip=0x7f7ced05ce72 code=0x0

Unfortunately thats as much information as I have, as it looks like ptrace denials aren’t hitting normal apparmor denials… As soon as the call is hit the process is insta-zombied and the Steam TaskManager believes it to be running still (requiring killall -9 HitmanPro)

Any clues on where to go from here…? Do I need to add seccomp rules too …?

Update: Turns out we need to explicitly add ptrace to our seccomp in the new interface. Marking this solved. :stuck_out_tongue: