[Solved] KompoZer Snap crashes

Hello. Sorry to say this, but I also experience that “KompoZer” does not run, and it strikes me as though my error messages are similar to what an earlier poster, of a closed thread, had reported. I’m using Debian 9 / Stretch, but this should not matter. This is my Konsole output (since mine is the Plasma 5.8 Desktop Manager):

dirk@Phosphene:~$ su
root@Phosphene:/home/dirk# snap install kompozer
Warning: /snap/bin was not found in your $PATH. If you’ve not restarted your
session since you installed snapd, try doing that. Please see
How to fix snap binaries not found for more details.

kompozer 0.8 from Snapcrafters installed
root@Phosphene:/home/dirk# exit
dirk@Phosphene:~$ kompozer
update.go:85: cannot change mount namespace according to change mount (/snap/gtk-common-themes/1514/share/gtk2/Materia-compact /snap/kompozer/4/share/themes/Materia-compact none bind,ro 0 0): cannot write to “/snap/gtk-common-themes/1514/share/gtk2/Materia-compact” because it would affect the host in “/snap”
update.go:85: cannot change mount namespace according to change mount (/snap/gtk-common-themes/1514/share/gtk2/Materia-dark-compact /snap/kompozer/4/share/themes/Materia-dark-compact none bind,ro 0 0): cannot write to “/snap/gtk-common-themes/1514/share/gtk2/Materia-dark-compact” because it would affect the host in “/snap”

(process:15547): Gtk-WARNING **: 16:52:39.853: Locale not supported by C library.
Using the fallback ‘C’ locale.
Gtk-Message: 16:52:39.950: Failed to load module “gail”

(process:15547): Gtk-WARNING **: 16:52:40.953: Locale not supported by C library.
Using the fallback ‘C’ locale.
Gtk-Message: 16:52:40.954: Failed to load module “gail”
Fontconfig warning: “/etc/fonts/fonts.conf”, line 160: blank doesn’t take any effect anymore. please remove it from your fonts.conf

(kompozer-bin:15547): Pango-WARNING **: 16:52:41.616: failed to create cairo scaled font, expect ugly output. the offending font is ‘Courier 8.9990234375’

(kompozer-bin:15547): Pango-WARNING **: 16:52:41.616: font_face status is: file not found

(kompozer-bin:15547): Pango-WARNING **: 16:52:41.616: scaled_font status is: file not found
Segmentation fault

BTW, Even though ‘/snap/bin’ is not in my $PATH when root, it is in my $PATH when user. Therefore, this warning doesn’t prevent me from running other snaps. Most snaps run fine, except for the fact that I’ve already discovered, that some snaps are just defective… I would look forward to seeing KompoZer run again, however.

Also, there is another observation about this, which I’d like to add. I cannot tell whether the Gtk-Message about ‘gail’ not being loaded is related to the crash. In certain cases, applications will just display such messages to the terminal, if launched from a terminal, but run anyway. What I can say is, that to link the Snap version of KompoZer to ‘gail’, strikes me as a bad decision.

The reason why I’d say this is, the observation that gail is installed out-of-the-box under Ubuntu, but not under Debian. To install the ATK and AT-SPI2 under Debian, if our distro doesn’t ship with it, is fraught with pitfalls. Environment variables need to be set globally, for the ATK really to become useful, and then one side-effect can be, that such application-suites as “LibreOffice” end up becoming unstable. In fact, under the Plasma 5.8 Desktop Manager and Debian 9 / Stretch, the way to get screen-reading to work, differs from how to do it under GNOME and Ubuntu.

Hence, even if a user was to set it up, the question to ask next would be, ‘To what extent is the ATK relevant to Web-design and HTML editing?’


The most obvious think I can check the output for snap version in the terminal. If you have the core snap involved, it will be version 2.49, if you don’t have core installed, it’ll be somewhere in the 2.2x range which is very very old to the point these kind of problems aren’t unexpected. So make sure you sudo snap install core and maybe reboot for good measure if it isn’t already

root@Phosphene:/home/dirk# snap version
snap 2.49.2
snapd 2.49.2
series 16
debian 9
kernel 4.9.0-15-amd64

core 16-2.49.2 10958 latest/stable can
core18 20210309 1997 latest/stable can
core20 20210319 975

root@Phosphene:/home/dirk# snap remove core18
error: cannot remove “core18”: snap “core18” is not removable: snap is being
used by snaps acrordrdc, dotnet-sdk, figma-linux, gnome-3-28-1804,
gtk-common-themes and 6 more.

Eureka. It would seem that I have 3 different versions of ‘core’ installed: ‘core’, ‘core18’ and ‘core20’.
What next?

FWIW, I’d say that the general level at which Snapd works on my box is good enough, that with a very small number of exceptions, ‘I can just install an arbitrary Snap and have it work.’ To test this premise, I just installed “Spotify” within the past 15 minutes, and it works 100%. Why did I choose to test Spotify? Because, according to certain other reports on the Web, Spotify doesn’t work, and produces messages at least, similar to what I get from KompoZer. On my box, Spotify actually generates no messages in the Konsole instead.

Also, just to be thorough, I did reboot. The result was exactly what I obtained before.


the original error above looks like a fontconfig issue, try running:

$ sudo rm -f /var/cache/fontconfig/*
$ rm -f ~/.cache/fontconfig/*

and see if that helps (a new font config should be generated on startup of the app then)

Thank You! That solved the problem for me! :grinning:


1 Like