[SOLVED] Can't install snaps UbuntuCore16 --> x509: certificate has expired

Hello everyone!

I’m trying to install snaps in Ubuntu Core 16 on a Raspberry Pi 3.
The issue is that when I do it (snap install aws-iot-greengrass, for instance ), I got the next message:

error: cannot install “aws-iot-greengrass”: Post
https://api.snapcraft.io/v2/snaps/refresh: x509: certificate has expired
or is not yet valid

I do have the SSH keys imported on the UbuntuOne Page (https://login.ubuntu.com/ssh-keys).

As well, if I enter to https://login.ubuntu.com/api/v2/keys/my_email%40email.com on any browser, I get a response with the SSH keys I have stored.

Any suggestion or idea what to do?

Thanks in advance

I found the problem.

It was due to my Raspberry’s date. It had a wrong date, even when it was connected to Internet.
I only changed it with:

date -s “30 SEP 2019 16:40:00”

  • Change “30 SEP 2019 16:40:00” for your current date :sweat_smile:

For now it works, but I think there should be another (more elegant) way to configure it.

1 Like