SOLVED - Cannot install snaps on Linux MX19 patito feo

Hi everyone,
I tried to install Mathpix on a Linux MX19 distro and following error happens:

$ sudo snap install mathpix-snipping-tool
error: cannot communicate with server: Post http://localhost/v2/snaps/mathpix-snipping-tool: dial unix /run/snapd.socket: connect: no such file or directory

I tried with Spotify and same problem:
$ sudo snap install spotify
error: cannot communicate with server: Post http://localhost/v2/snaps/spotify: dial unix /run/snapd.socket: connect: no such file or directory

Following information retrieved:

$ systemctl status snapd.service
System has not been booted with systemd as init system (PID 1). Can’t operate.
Failed to connect to bus: El `host’ no está operativo

$ snap version
snap 2.37.4-1+b1
snapd unavailable
series -

$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

$ uname -a
Linux tortuga 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux

Any idea about what is hapenning?
Thanks
Fernando

It looks like your distro doesn’t use systemd. AFAIK systemd is required (or at least assumed) by snapd.

1 Like

Hi elcste!

I found the solution. MX Linux is not booted by default with systemd. But in the GRUB screen selecting Advanced options, boot with systemd can be selected. In addition, /snap/bin shall be added as user PATH. Please refer to the following link
https://mxlinux.org/wiki/applications/snap-packages-and-mx-linux/

Thanks
Fernando

1 Like