hi, i have a probleme her :slightly_smiling_face: aym@kali:~$ sudo snap install snap-store [sudo] password for aym: error: cannot install “snap-store”: Post “”: parse “http://<proxy_addr>:<proxy_port>”: invalid port “:<proxy_port>” after host please help me

Do you use a http proxy? It looks like your proxy somehow got set verbatim to http://<proxy_addr>:<proxy_port>

how get the proxy _addr and prot when should be added this http proxy

What is the output of

sudo snap get system proxy

and the output of

sudo cat /proc/$(systemctl show snapd -p MainPID | grep -Po '=\K.*')/environ | grep -a PROXY

sudo cat /proc/$(systemctl show snapd -p MainPID | grep -Po ‘=\K.*’)/environ | grep -a PROXY
cat: /proc/0/environ: No such file or directory

What is the output of systemctl status snapd and journalctl --no-pager -u snapd` ?

$ systemctl status snapd
● snapd.service - Snap Daemon
Loaded: loaded (/lib/systemd/system/snapd.service; enabled; vendor preset:>
Active: inactive (dead) since Fri 2020-09-18 02:37:56 HST; 3h 19min ago
TriggeredBy: ● snapd.socket
Process: 72479 ExecStart=/usr/lib/snapd/sn

Can you paste the results of the second command, journalctl --no-pager -u snapd?

$ journalctl --no-pager -u snapd
Hint: You are currently not seeing messages from other users and the system.
Users in groups ‘adm’, ‘systemd-journal’ can see all messages.
Pass -q to turn off this notice.
– Logs begin at Wed 2020-09-16 06:07:39 HST, end at Fri 2020-09-18 07:41:16 HST. –
– No entries –

how fix that please help me I need this store

try using sudo for the journalctl command above, the message it prints suggests that you can not read the system logs as normal user on this installation (which is a quite weird setup) …

also what is the full output of snap version ?

snap 2.45.2-1
snapd 2.45.2-1
series 16
kali 2020.3
kernel 5.8.0-kali1-amd64

sudo journalctl --no-pager -u snapd

Sep 19 04:30:12 kali systemd[1]: Starting Snap Daemon…
Sep 19 04:30:12 kali snapd[75437]: AppArmor status: apparmor is enabled but some kernel features are missing: dbus, network
Sep 19 04:30:13 kali snapd[75437]: daemon.go:343: started snapd/2.45.2-1 (series 16; classic; devmode) kali/2020.3 (amd64) linux/5.8.0-kali1-amd64.
Sep 19 04:30:13 kali snapd[75437]: daemon.go:436: adjusting startup timeout by 30s (pessimistic
estimate of 30s plus 5s per snap)
Sep 19 04:30:13 kali systemd[1]: Started Snap Daemon.
Sep 19 04:30:13 kali snapd[75437]: api.go:990: Installing snap “snap-store” revision unset
Sep 19 04:30:13 kali snapd[75437]: stateengine.go:150: state ensure error: Get “”: parse “http://<proxy_addr>:<proxy_port>”: invalid port “:<proxy_port>” after host

how Reinstall this package

What’s the output of env | grep proxy please?
It looks like your proxy configuration is incorrect.


the output is nothing

I wonder if <proxy_addr> and <proxy_port> is displayed verbatim, or it is just a placeholder for some regular values?

I also wonder if you’re using Kali Linux, as it may be an environmental issue.

yes i use kali linux .
why the snap-store not working in kali linux

I tried to reproduce this by installing Kali in a VM then updating the packages. Unfortunately once updated, Kali completely broke, giving me a black screen after login. So I can’t easily debug this, sorry.

1 Like

other time please ok thank you