Snap's "zoom-client" won't close that easily. Need multiple attempts to exit the app!

I installed ZOOM using snap install zoom-client command. Opened it. Tried to close it using a shortkey (Super A) that I created using GNOME settings, didn’t work. Tried using mouse courser to click in a red cross which meant of exit the app, didn’t work. You need to press exit option three times. One is NOT enough. I have tested this multiple times. Clicking exit one time will do nothing even if I wait for couple of hours. And you want to close exactly how I close. So, pressing Super key can become mandatory. Weird. Because if u close it normally, it will minimize :woozy_face:. Like seriously, what the…

So, I was wondering whether this is a known issue of not. I want to get this issue addressed. Screencast%20from%2008-30-2020%2009%2038%2015%20AM

Distro: Ubuntu 20.04 DE: GNOME 3.36.3

this is by design … zoom decided you can only close the app via the close menu item from the panel menu (and this works absolutely reliable here, do you have any probs closing it that way ?)… if you really manage to close it via a shortkey or the window close button, that micht be a bug though (note that the deb version they provide is even started with nohup which means you can not close it at all, even when using the indicator menu option as you should)

1 Like

Oh, I just tried their deb package, you are right.

Flaw in design of their app.

This also drove me nuts. As of 12/10/20 at least, there is a setting to turn this behavior off: