Snaps show squares instead of fonts

I need help. I don’t know what happened but starting today every installed snaps shows weird squares instead of fonts. When launched via terminal the snap store shows several errors (see image below). I’m running Pop!OS 20.04 LTS and snapd 2.45.


Ok, I found a solution here:

rm -rf ~/.cache/fontconfig && sudo fc-cache -r -v

Thank you anyway :slight_smile:

For completeness can you provide the output of dpkg -l |grep fontconfig ?

ii  fontconfig                                       2.13.1-2ubuntu3                                      amd64        generic font configuration library - support binaries
ii  fontconfig-config                                2.13.1-2ubuntu3                                      all          generic font configuration library - configuration
ii  libfontconfig1:amd64                             2.13.1-2ubuntu3                                      amd64        generic font configuration library - runtime
ii  libfontconfig1:i386                              2.13.1-2ubuntu3                                      i386         generic font configuration library - runtime

@mborzecki Following up here, I maintain Beekeeper Studio and I’m seeing this issue:

  1. Freshly install Fedora 32 Desktop (Virtualbox)
  2. Install Snapd
  3. sudo snap install beekeeper-studio
  4. Open Beekeeper and try to open a sqlite file

Result: Missing fonts in the file picker.


This is a 100% fresh install. I also tried the AppImage version of Beekeeper, which works totally fine.
Is my app missing an interface or something? Here are the interfaces connected:

[rathboma@localhost ~]$ snap connections beekeeper-studio
Interface                 Plug                              Slot                             Notes
audio-playback            beekeeper-studio:audio-playback   :audio-playback                  -
browser-support           beekeeper-studio:browser-support  :browser-support                 -
content[gnome-3-28-1804]  beekeeper-studio:gnome-3-28-1804  gnome-3-28-1804:gnome-3-28-1804  -
content[gtk-3-themes]     beekeeper-studio:gtk-3-themes     gtk-common-themes:gtk-3-themes   -
content[icon-themes]      beekeeper-studio:icon-themes      gtk-common-themes:icon-themes    -
content[sound-themes]     beekeeper-studio:sound-themes     gtk-common-themes:sound-themes   -
desktop                   beekeeper-studio:desktop          :desktop                         -
desktop-legacy            beekeeper-studio:desktop-legacy   :desktop-legacy                  -
gsettings                 beekeeper-studio:gsettings        :gsettings                       -
home                      beekeeper-studio:home             :home                            -
network                   beekeeper-studio:network          :network                         -
opengl                    beekeeper-studio:opengl           :opengl                          -
pulseaudio                beekeeper-studio:pulseaudio       -                                -
ssh-keys                  beekeeper-studio:ssh-keys         -                                -
unity7                    beekeeper-studio:unity7           :unity7                          -
wayland                   beekeeper-studio:wayland          :wayland                         -
x11                       beekeeper-studio:x11              :x11                             -

same problem for years now… do we need to start a new thread about this?

I’m being told the problem is fixed in recent snapcraft releases, provided snaps use the right extensions. (cc @sergiusens).

The other side of the problem is that whoever published a given snap must sufficiently care about their work to basically rebuild the snap using the latest version of snapcraft.

@mborzecki that’s nice to hear. I’m sorry for this maybe dumb question but could you provide me a simple way to verify the snapcraft used by a specific snapcraft?
and just to be complete, let’s say it’s the case, I can confirm that it’s not okey for bitwarden,, signal, mattermost, standard-notes…

There should be a snap/manifest.yaml file in the snap which will list which snapcraft version was used to build it. Though it’s rather unlikely to be there if the snap is a proprietary application.

Still having the same issue, now on Manjaro gnome, with snapd 2.52.1. my solution didn’t worked this time. I’m stuck with unusable snaps and squares everywhere instead of readable text. :frowning:

1 Like

I have the same issue using Discord snap package. Whenever I hit the browse button I am welcomed by this squared goliath.

Seems like today with version 3.9.20 I’ve got the same issue what was the solution?

Have you tried this?

I did, will try again just to be sure.

Btw it says:


Is there maybe a particular font I need to install?