Snaps only run after a long timeout


#1

Hi,

my snap applications only start after a long delay. The error message is:

2018/12/28 17:23:36.861954 cmd_run.go:844: WARNING: cannot start document portal: Failed to activate service ‘org.freedesktop.portal.Documents’: timed out (service_start_timeout=120000ms)

It affects all snap applications I have on my system (gimp, libreoffice, inkscape)

It only started recently. Is this a known issue?

Amir


#2
  1. Can you please show us the output of snap version?
  2. Is the problem limited to GUI applications or do command-line applications also exhibit the delay?
  3. Have you tried rebooting or at least running systemctl restart snapd and trying again?

#3

Hello Daniel.

No problem. Outputs bellow. Problem seems limited to GUI applications (thanks for the tip, I never had non-GUI snaps before).

I have apt remove snapd apt install snapd and reboot. I have now tried systemctl restart snapd and no change occurred. I have also tried other things. The org.freedesktop.portal.Documents causing the timeout seems to come from flatpak, so I uninstalled flatpak and reinstalled it from the alexlarsson ppa. No change. Tried installing the apps I had as snaps as flatpaks (GIMP, Inkscape and Libreoffice bc of the versions in the official repos) and there was a delay (like 10 seconds), but that is also not acceptable. For now, I searched for ppas with latest software versions and installed them via apt, but I would like to be able to use snaps. This must have come with one of the recent bionic updates.

:~$ snap version
snap 2.36.3
snapd 2.36.3
series 16
ubuntu 18.04
kernel 4.15.0-43-generic

time snap run gnome-calculator
2018/12/29 19:40:37.096160 cmd_run.go:844: WARNING: cannot start document portal: Failed to activate service ‘org.freedesktop.portal.Documents’: timed out (service_start_timeout=120000ms)
main.go:224: cannot change mount namespace of snap “gnome-calculator” according to change mount (/snap/gtk-common-themes/818/share/icons/Suru /snap/gnome-calculator/260/data-dir/icons/Suru none bind,ro 0 0): cannot use “/snap/gtk-common-themes/818/share/icons/Suru” as bind-mount source: not a directory
Gtk-Message: 19:40:39.213: Failed to load module “appmenu-gtk-module”
Gtk-Message: 19:40:39.278: Failed to load module “topmenu-gtk-module”
Fontconfig warning: “/etc/fonts/conf.avail/53-monospace-lcd-filter.conf”, line 10: Having multiple values in isn’t supported and may not work as expected

** (gnome-calculator:3813): WARNING **: 19:40:40.799: currency.vala:282: Unknown currency ‘Bolivar Soberano’

** (gnome-calculator:3813): WARNING **: 19:40:40.808: currency.vala:412: Currency VEF is not provided by IMF or ECB

real 1m46,018s
user 0m0,598s
sys 0m2,209s

(closed right after start)
:~$ snap run mapscii
ERROR: ld.so: object ‘libgtk3-nocsd.so.0’ from LD_PRELOAD cannot be preloaded (failed to map segment from shared object): ignored.

⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡿⢿⣆⠀⠀⠀⠀⠀⠀⠀⠀⠀⢨⣿⠟⠃⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠞⠋⠀⠀⢀⣼⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡿⢿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿
⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡟⠀⠈⠻⣦⣶⣦⠄⠀⠀⠀⠀⢰⣿⠋⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⢀⣠⣴⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡿⠟⠟⠻⢿⣿⣿⣿⣿⣿⣿⣿⣿⣿⢻⣫⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠏⠀⠘⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿