Snaps not installing associated command

Snapcraft and Linux newbie here, running GalliumOS (Xbuntu/Ubuntu fork). When a snap is installed (e.x. $ snap install hello) thee associated command to run it doesn’t work (e.x. $ hello). Note that this takes place with every snap that I’ve tried, even when going step-by-step through the tutorial. Any help would be appreciated.

Run printenv | grep ^PATH= in the terminal then verify if /snap/bin is in your shell’s command search PATHs.

Typically after installing snapd for the first time you need to log-out and log-in back to have updated PATH and other things. Just give it a try!

1 Like

I logged out and back in, rebooted, and suspended, all to no avail.

It was not, I added it with the info here:
Don’t know why, perhaps snapd didn’t finish installling and I cut it off somehow? Whatever the case, adding the path manually worked.

Which shell are you using? Currently (default) bash works great but if you use other shells you may need to tweak things furtherer yourself.