Snaps GITKRAKEN failed to start since update


#1

Hello everyone,

SInce the last update of Gitkraken (4.0.6) with snapcraft, it can’t start anymore.
I try ti launch it through command line and i have this error :

main.go:192: cannot change mount namespace of snap “gitkraken” according to change mount (/snap/gtk-common-themes/701/share/icons/Suru /snap/gitkraken/131/share/icons/Suru none bind,ro 0 0): cannot use “/snap/gtk-common-themes/701/share/icons/Suru” as bind-mount source: not a directory

I’m on Fedora 28.

Any help please ?

Regards.


#2

That error is not related to GK but it is with the gtk-common-themes snap that have issues on suru icon theme atm, can you add more information regarding the issue you are having.

did you tried removing /home/$USER/snap/gitkraken directory and running the snap again as GK have switched to gtk3 could be causing issues with old data of gtk2.


#3

Ok i try and tell you if it has worked


#4

Nope, it’s not working.

I deinstall gitkraken, delete the folder indicated. Reboot.
And i still have the problem.

For information, the first error i have was a:
ln: failed to create symbolic link ‘/home/…/gtk-2.0/gtkfilechooser.ini’: File exists
After this error i deinstall gitkraken and reinstall it through snap.
But i have now the error on Suru. And i still have it, even after deleting the folder.

Any other ideas please ?

Regards.


#5

Here the exact first error i have :
ln: failed to create symbolic link ‘/home/project/snap/gitkraken/131/.config/gtk-2.0/gtkfilechooser.ini’: File exists


#6

do the app work or just crashes?

can you post info of these

snap info core
snap version
snap interfaces gitkraken


#7

Here the info

[*****@localhost ~]$ sudo snap info core
name: core
summary: snapd runtime environment
publisher: Canonical✓
contact: snaps@canonical.com
license: unset
description: |
The core runtime environment for snapd
type: core
snap-id: 99T7MUlRhtI3U0QFgl5mXXESAiSwt776
tracking: stable
refresh-date: today at 10:47 CEST
channels:
stable: 16-2.35.4 (5662) 92MB -
candidate: 16-2.35.5 (5742) 92MB -
beta: 16-2.35.5 (5742) 92MB -
edge: 16-2.36~pre2+git967.54466bd (5787) 92MB -
installed: 16-2.35.4 (5662) 92MB core

[*****@localhost ~]$ snap version
snap 2.35-1.fc28
snapd 2.35-1.fc28
series 16
fedora 28
kernel 4.18.14-200.fc28.x86_64

[*****@localhost ~]$ snap interfaces gitkraken
Slot Plug
:browser-support gitkraken
:desktop gitkraken
:gsettings gitkraken
:home gitkraken
:network gitkraken
:opengl gitkraken
:unity7 gitkraken
:wayland gitkraken
:x11 gitkraken
gtk-common-themes:gtk-3-themes gitkraken
gtk-common-themes:icon-themes gitkraken
gtk-common-themes:sound-themes gitkraken

  •                           gitkraken:removable-media
    
  •                           gitkraken:ssh-keys

#8

all looks good to me

For now just revert to old version if you are OK with this till this issue is resolved also I’ve pushed old release to candidate channel.

snap refresh gitkraken --candidate


#9

The revert working fine and gitkraken working on this old version.
Thanks for your help.

I’m waiting for the correction in the future

Thank you very much


#10

I can reproduce this as well. Looks like a bug with the desktop helpers? CC @kenvandine is this something you are aware of?


#11

I can reproduce at my end.

$ snap info gitkraken
commands:
  - gitkraken
snap-id:      jSAPVgfJG3rZdjyEcdvD7QLpXG5iLOX6
tracking:     beta
refresh-date: today at 09:41 +07
channels:                          
  stable:    –                 
  candidate: –                 
  beta:      4.0.6 (1) 196MB - <
  edge:      ↑                 
installed:   4.0.6 (1) 196MB - 

$ snap version
snap    2.36-1.fc29
snapd   2.36-1.fc29
series  16
fedora  29
kernel  4.18.17-300.fc29.x86_64

#12

Hello,

The application updated itself and now it’s not working again.
Even the candidate command not worrect it.

snap-id: aWUrHnWTzA1R71VuWsBG5v8S0ibIxmjR
tracking: candidate
refresh-date: today at 11:15 CET
channels:
stable: 4.1.1 (134) 199MB -
candidate: 4.1.1 (134) 199MB -
beta: ↑
edge: 4.1.1 (134) 199MB -
installed: 4.1.1 (134) 199MB -


#13

And i come back to the first error :
ln: failed to create symbolic link ‘/home/********/snap/gitkraken/134/.config/gtk-2.0/gtkfilechooser.ini’: File exists


#14

Hello,

I’m still not be able to use gitkraken with the last version.
Somebody succeed to use on Fedora 29 ?

Regards.