Snapd service not running, cant restart

Tried installing the core snap as part of the initial instructions:

(xenial)leoamaro01@localhost:~$ sudo snap install core

error: cannot communicate with server: Post http://localhost/v2/snaps/core: dial unix /run/snapd.socket: connect: no such file or directory

Then I ran systemctl status snapd.service and got this:

(xenial)leoamaro01@localhost:~$ systemctl status snapd.service

Failed to get properties: Launch helper exited with unknown return code 1

Then I tried starting the service:

(xenial)leoamaro01@localhost:~$ systemctl start snapd.service

Failed to add /run/systemd/ask-password to directory watch: No such file or directory

Failed to start snapd.service: Launch helper exited with unknown return code 1

See system logs and 'systemctl status snapd.service' for details.

(xenial)leoamaro01@localhost:~$ sudo service snapd start

snapd: unrecognized service

I am using a Chromebook with Crouton installed and Xfce (Ubuntu 16.04) Desktop Environment and I am quite new to Linux, please help!

1 Like