Snapd on Raspbian (jessie)


#1

Hey everyone,

through the last days I worked getting snapd running on Raspbian which is based on Debian 8 (jessie). I have initial packages for this available now and want to invite more people to help testing these packages on their raspbian systems.

The package archive currently only contains a snapd package and nothing else. You can add it to your existing raspbian based system with:

PLEASE NOTE: This is not a official distribution of snapd. Its work-in-progress and should not be used on any production system.

$ sudo -s
$ cat << EOF > /etc/apt/sources.list.d/snapd.list
deb https://mm.gravedo.de/raspbian/ jessie main
EOF
$ apt update
$ apt install -y snapd

Afterwards you have snapd installed on your system and can use it as normal. Please note that snapd on raspbian comes without any confinement at the moment.

Known issues:

  • /snap/bin is not added to the list of secure paths for sudo so you have to provide the absolute path when running any snap command via sudo.

If you find any further issues please let me know.

regards,
Simon


#2

NOTE: as a quick reminder, this will NOT work the Raspberry PI 1 or the Raspberry PI zero because of incompatible hardware (the CPU is too old)


#3

I’ve forwarded this to Eben Upton, I’m going to be travelling until the middle of next week but will give this a test when I return :slight_smile:


#4

why would it not work on a Pi1 or zero ? AFAIK the snapd binary was recompiled for raspbian so it should support ARMv6 (which the Pi1 and zero models use)


#5

Because there is no core snap for that architecture. Sure, it will “work” until you try any snap.

Note that due to another bug snapd on arm6l thinks it is running on armhf so it will happily download the wrong snaps from the store.


#6

thanks, i didnt think of the core snap …


#7

Great! But how about this error?

Fel https://mm.gravedo.de jessie/main armhf Packages       
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
W: Misslyckades med att h�mta https://mm.gravedo.de/raspbian/dists/jessie/main/binary-armhf/Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

#8

This very much looks like your system doesn’t trust either the LetsEncrypt or IdentTrust root certificates. See https://letsencrypt.org/certificates/ for which certificates you need.

However on my system this works flawlessly. Could it be that the SSL CA setup on your raspbian system is somehow broken or is this a clean install of raspbian?


#9

Hey I am trying to install snapd on my raspian jesse but ran across the following problem

apt install -y snapd returns with the error

The following packages have unmet dependencies:
snapd : Depends: apparmor (>= 2.10.95-0ubuntu2.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What sould I do to make it work?

Thank you very much!


#10

Hm, I thought I dropped that dependency. Let me correct that and upload a new version of the package later today.


#11

Thank you for your quick reply!
Please let me know when you get to it. I am eager to test it out.


#12

I’ve updated the repository now to include the apparmor package. Can you try again?


#13

Installation was successful. Thank you very much. I am going to try some snaps now.


#14

Great! Let me know if you run into any other problems.


#15

The repository is now updated to include snapd 2.26.4 and detects armv6l and prevents installation of armhf core snaps on these devices. This means that snapd will now work properly on the Raspberry Pi 1 and Zero but as we don’t have a core snap or any other snaps available will be non functional.


#16

Morphis,

I had to use the --force-yes switch but it seemed to install ok. I’ll play with it a bit and let you know how it works. Given that we had huge kernel issues with Ubuntu 16.04 on Raspberry Pi V3, we had to go back to Raspian, If it works this will be very helpful. Thanks for your efforts.


#17

OK. Already have an issue as it can’t seem to find our snap’s on the Ubuntu store. Is there something we need to do to get access to the store?


#18

No. I guess the snaps you’re looking for are not published for the armhf architecture then.


#19

We have a user that installed snapd on raspbian after following the instructions in the original post. Installing on an rpi2

But is getting this error:

ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object

Output of snap --version

snap 2.26.4+git5.gc87f366.dirty
snapd 2.26.4+git5.gc87f366.dirty
series 16
raspbian 8
kernel 4.4.34-v7+

Output of snap list

pi@raspberrypi:~ $ snap list
Name Version Rev Developer Notes
core 16-2 1690 canonical -
rocketchat-server 0.57.0-develop 787 rocketchat -

He’s tried with both stable and edge with our rocketchat-server snap. The stable is for sure confirmed to work on ubuntu core on an rpi3.


#20

Do you have any apparmor denials? Eg: grep DEN /var/log/syslog