Snapd on clearlinux

I’ve built snapd on clearlinux, and I was having trouble with an error:

cannot locate the core snap: No such file or directory

I googled for a few hours and found someone with a similar problem that had an unknown OS in their /etc/os-release so I changed my os-release id from clear-linux-os to archlinux and rebooted.

Now everything works fine.

Any suggestions on a better way to fix this?

1 Like

For reference, the contents of os-release:

NAME="Clear Linux OS"
PRETTY_NAME="Clear Linux OS"


Could you please share the build-depends? I was trying to do this a while ago but got stuck getting the right autotools packages installed.

To build snapd on clear linux I had to add the bundles: go-basic devpkg-libseccomp kvm-host-dev


also, be careful messing with your os-release file. make a backup if you’re going to change it, as it breaks swupd

1 Like

Hi guys,

Could you please help me with building snapd on clearlinux.
I’m stuck on this step from file:
./configure --prefix=/usr --libexecdir=/usr/lib/snapd --enable-nvidia-biarch --with-host-arch-triplet=x86_64-generic-linux

I got this error:

configure: error: Package requirements (libapparmor) were not met:

No package ‘libapparmor’ found

After this I’m built and install libapparmor from the sources.
But I still get the same error.

Anyone who successfully build snapd on clearlinux can help me with this step?

IIRC Clear Linux does not supprot AppArmor and has no /usr/lib/<triplet> like Debian distros do. Your chances are better if you start with the same flags as Fedora, --merged-usr --disable-apparmor --enable-nvidia-biarch