Snapd not running in CI - how to start?

Linux/snap noob here. I’m trying to get snap working in a CI environment (GitLab) but am having troubles.

The environment is KDE Neon (Xenial) but running snap --version suggests that things aren’t running correctly:

$ snap --version
snapd   unavailable
series  -

I’ve scoured the docs for how you might ‘start’ snapd if snap is already installed but can’t find anything. I had the same issue running an image of straight Ubuntu 18.0 in CI.

Any help would be greatly appreciated.

systemctl start snapd should do, if not check systemctl status snapd

Thanks for the advice. I tried both suggestions (start and status) but they return the same error:

Failed to connect to bus: No such file or directory

Any ideas what that could be?

Aaaah, this appears to be related to the fact that I’m doing this all in Docker:

Sorry for the noise!


k@danb I have run into the same problem. May I ask what did you do to work around and get snapd working in CI docker?

Snapd depends on systemd, so unless you can make a systemd instance available in Docker it won’t work.


My workaround was to not use Docker in the end :slight_smile:

1 Like