Snapd not installing microstack

Dear All,

On ubuntu 20.04 and 18.04 and 21.04, Snapd couldn’t install microstack with beta channel but succeeded with edge channel. Error message was as below:

~$ sudo snap install microstack --beta

error: cannot perform the following tasks:

- Mount snap “microstack” (242) (installation not allowed by “kernel-module-control” plug rule of interface “kernel-module-control”)

With sucessfuly edge channel installation, dashboard GUI didn’t show properly with no picutre showing up.

Any suggestion would be appreciated! Thanks.

The beta channel of microstack still requires the --devmode flag when being installed as the strict confinement pieces have not been promoted to the beta channel yet as we were testing it a bit still. Testing revealed the same issue with the dashboard UI that you’ve reported here and a patch is up to fix it, which should hopefully land soon.

Have the same issue but with --devmode option

sudo snap install microstack --beta --devmode

error: cannot perform the following tasks: - Mount snap “microstack” (242) (installation not allowed by “kernel-module-control” plug rule of interface “kernel-module-control”)

Option --edge was installed but has some type of issue with web interface (nginx is OK, but no contents displays)

Thanks Billy. As Alex mentioned, it still didn’t work with flag --devmode. As for UI issue, is there a manual fix? Thanks for the quick response.

Hi Justin! Seems like I got the solution to resolve an issue on --edge Here is a bug I reported:

according to this you just need to change: /var/snap/microstack/common/etc/horizon/local_settings.d/_05_snap_tweaks.py set there DEBUG = True and restart microstack services

Awesome, Alex. I’ll give it a go. Thanks.

worked like a charm. thanks Alex.

Meanwhile, I was able to get it running, by using the Edge branch. I’d hardly advise it, but should you be in a hurry, you can use the dev branch:

sudo snap install microstack --edge --devmode

This should do the trick, until the fix hits Beta branch.

fwiw, --devmode is no longer required in the edge channel.

without --devmode you’ll get a number of issues on UI ( try to access instances there )

I can only confirm that snap does not install MicroStack beta in dev mode in ubuntu 20.04.

It worked before X-mas.

I am developing Ansible automation scripts using MicroStack for testing and debugging of those scripts.

Unfortunately the edge version does not run my Ansible scripts (for host creation) as I get random errors (that I have not yet analyzed) that does not come up in beta.

Consequently I am stuck here…

Is there a way to get MicroStack beta from before X-mas installed or is there an upgrade that will once more install the beta version due any time soon.

Lots of thanks in advance for any help I can get!!!

Regards

Hans

Hi All,

I am also facing similar issue with option --beta --devmode Tried installing --egde --devmode, --classic --edge and --classic --beta getting below error while init command

File “/snap/microstack/244/lib/python3.8/site-packages/init/shell.py”, line 69, in check raise subprocess.CalledProcessError(proc.returncode, " ".join(args)) subprocess.CalledProcessError: Command ‘openstack project create --domain default --description “Service Project” service’ returned non-zero exit status 1.

I thought to revert to some older revision something like sudo snap install microstack --devmode --edge --revision=242

This is giving access error error: cannot install “microstack”: Access by specifying a revision is not allowed for this Snap.

Could someone please suggest how to resolve this. Thankyou

Since latest MicroStack beta (242) was released on November 18’th 2021 and installation of that snap worked perfectly on Ubuntu 20.04 just before X-mas I draw the conclusion that something else has changed in the system, the question is what? Snapd, the kernel, something else?

The random problems I am now phasing with edge version seems to be related to network timeout issues that I haven’t seen before in beta (like an apt-get install in a guest server fails randomly etc).

Any suggestions anyone?

The problem behind this will probably be fixed with this bug:

Why it worked for me for a month I do not know.

Best workaround for me was to install edge in devmode:

sudo snap install microstack --devmode --edge

(There seems to be a bug in edge that will make virsh crash but with --devmode this does not happen to me.)

Also do not forget to patch the WEB GUI like:

sudo sed -i ‘s/DEBUG = False/DEBUG = True/g’ /var/snap/microstack/common/etc/horizon/local_settings.d/_05_snap_tweaks.py

sudo snap restart microstack.horizon-uwsgi

Hope this will help someone.