Snapd Installed gmail-desktop Problem

A couple of years ago I installed gmail-desktop using snap, as the installation instructions specified, on my Linux Mint computers. It worked perfectly up till about two weeks ago. At that time, when I opened gmail-desktop to check my emails, I found that I couldn’t access those emails anymore. It displays the folders as before, and shows when email enters the Inbox, but I can’t open the emails, or the folders they are in. I didn’t know where to go with this question, so I’m asking here for help, and have also placed a help request on the gmail community forum. Haven’t had a response from that forum. Is this a problem with snapd, or a direct gmail problem? I can still access my gmail on Google Chrome, but I like the gmail-desktop because I didn’t need to open the browser to get my emails with it. Anyone have any idea what has happened? Thanks.


Yes, I saw that, and it isn’t the same issue. I can log into my gmail account with the app, and view what is happening, but it won’t let me open my emails. Like I said, this problem started very recently, and the app worked perfectly for nearly two years before that.

well, did you read the thread to the end ? there is a link to report your issue to the snap packager …

No, all I saw was the one post you quoted. I’ll see if I can pull up the rest of the thread. Thanks.