Snapd doesn't install nor run properly, no GTK theme applied to Snap Store, no fonts displayed [Arch Linux] [Fedora]

Hello

Sorry, new users can only put 2 links in a post.

So bare with be while I try my best to properly link the problems. Just copy’em out of single quotes to get them working.

Sorry, new users can only put one image in a post.

Sigh… Not sure what to do, I’ll upload the most relevant one I guess.

EDIT: To help speed up things, I’ve made a makeshift repo with a README.md with a duplicate of this post but with all the links and images included. I’ll use my single link allowed to do this:

----> Snapd doesn’t install nor run properly, no GTK theme applied to Snap Store, no fonts displayed [Arch Linux] [Fedora]


My name is Cristiano Vitorino, I’m a Designer, helping out with the UI Rewrite on the [Glimpse](https://glimpse-editor.org/) project.

@hellsworth sent me this way from the Glimpse Matrix channel after our discussion about bugs and problems I’ve encountered trying to use snapd on Arch Linux and also my past problems with it on Fedora 30 and 31.

I want to thank her for her patience and composure in trying to help me while I was extremely frustrated with snapd after failing to get it to work on my production machine where I need Glimpse to be stable.

So, I’ll sumirise my recent problems and my past ones soon after. Also I’ll mention everything that I managed to find online about these same issues.

I understand that my distros of choice are bleeding edge and I take that into consideration when bug reporting. Specially my beloved Arch Linux, that is unique for each install, and a hellscape to debug.

For record sake, today is 23.Mar.2020. Spent the evening trying to solve these problems.


  1. The Installing snap on Arch Linux page on https://snapcraft.io/docs/installing-snap-on-arch-linux is outdated. There are additional steps required now to get snapd installed or removed.
Last updated 1 year, 30 days ago. Help improve this document in the forum.

The first step still holds true:

$ git clone `https: //aur.archlinux.org/snapd.git`
$ cd snapd
$ makepkg -si

But not the second:

$ sudo systemctl enable --now snapd.socket

Enabling the seeded service is required BEFORE enabling snapd.

$ sudo systemctl enable snapd.seeded.service
$ sudo systemctl enable --now snapd.socket

Otherwise you will get this error:
https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/seeded-error.png

If you try again, it usually works:
https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/seeded-error-2.png

The remaining steps still holds true.

Special thanks to [Erik Dubois](https://github.com/erikdubois) for creating [this script](https://github.com/erikdubois/arcolinux-nemesis/blob/aefa1adcac4c7a4fc0719921d838cf1f28057d89/AUR/install-snap-and-snap-store-v1.sh) that solves the problem.


  1. Uninstalling snapd requires extra steps and should be mentioned on the install page. This is a safety/sanitary approach to uninstalling snapd on Arch Linux, on that order:
$ sudo systemctl stop --now snapd.socket
$ sudo systemctl stop snapd.seeded.service
$ sudo systemctl disable --now snapd.socket
$ sudo systemctl disable snapd.seeded.service
$ sudo pacman -Rs snapd

OR

$ yay -Rs snapd
$ reboot

  1. Installing snapd from AUR with yay gives a perpetual error, snapd is broken forever, it complains about the seeded issue forever. I’ve found no solution for this.

Major problem #1

I’m unable to use Snap Store due to it’s inability to display text/font. Also it doesn’t recognize the applied GTK theme and defaults to an odd and seemly old version of GTK. Screenshots below for reference.

https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/no-font-no-gtk.png

https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/no-font-no-gtk-2.png

Major problem #2
I’m unable to run Glimpse (glimpse-editor). It starts, tries to load, and as soon as it opens, a split second later it crashes. Oh, it also have the same bug with the text/font that the Snap Store one has. Screenshots for reference.

https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/glimpse-loading-no-font.png

https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/glimpse-crash.png


  1. Relevant links to either these exact same issues or similar ones, old and new, still here unfortunately:
  • Jul.2019 - [Snapped app not loading fonts on Fedora (and Arch)](https://forum.snapcraft.io/t/snapped-app-not-loading-fonts-on-fedora-and-arch/12484)
  • Feb.2018 -[Snap application icons do not appear with Wayland](https://bugs.launchpad.net/snapd/+bug/1747081)
  • Nov.2017 [fonts missing #8](https://github.com/snapcrafters/discord/issues/8)
  • Oct.2019 - [[SOLVED] Snap-Store font problem?](https://arcolinuxforum.com/viewtopic.php?f=35&t=1631) # This solution no longer works. At least on vanilla Arch Linux.
  • Jul.2019 -[Snap-store dont display text](https://forum.snapcraft.io/t/snap-store-dont-display-text/12219) # Exact same problem of the first link, and on the same month.
    • Oct. 2019 - @mborzecki had extra insight [here](https://forum.snapcraft.io/t/snap-store-dont-display-text/12219/13) that might be of some help.
  • Oct.2019 - [Snap Store Font issue - everything is a rectangle (screenshot)](https://forum.manjaro.org/t/snap-store-font-issue-everything-is-a-rectangle-screenshot/105932)
  • May.2017 - [Use the system gtk theme](https://forum.snapcraft.io/t/use-the-system-gtk-theme/496)

My system info

https://raw.githubusercontent.com/cristianovitorino/snapd-bug-report/master/sys-info.png

snapd version: snapd 2.43.3-1

$ cat /etc/os-release

NAME="Arch Linux"
PRETTY_NAME="Arch Linux"
ID=arch
BUILD_ID=rolling
ANSI_COLOR="0;36"
HOME_URL="https://www.archlinux.org/"
DOCUMENTATION_URL="https://wiki.archlinux.org/"
SUPPORT_URL="https://bbs.archlinux.org/"
BUG_REPORT_URL="https://bugs.archlinux.org/"
LOGO=archlinux

uname -a

Linux desktop 5.5.10-arch1-1 #1 SMP PREEMPT Wed, 18 Mar 2020 08:40:35 +0000 x86_64 GNU/Linux

cat /proc/version

Linux version 5.5.10-arch1-1 (linux@archlinux) (gcc version 9.3.0 (Arch Linux 9.3.0-1)) #1 SMP PREEMPT Wed, 18 Mar 2020 08:40:35 +0000

Important Notes

  • Somehow installing snapd breaks my .Xmodmap file and renders it useless. I have zero idea how or why. I blame ghosts.
  • Please, PLEASE, someone responsable for documentation on Snapcraft add a echo snap >> ~/.hidden to every install page right after reboot so people stop complaining about making /snap hidden. This is a minor cosmetic issue that shouldn’t be an issue. Thank you.
  • I faced very similar issues when I tried snapd on Fedora 30 and Fedora 31.

Steps to reproduce

Arch Linux

I’ve uploaded my Arch Linux install guide with each step I use to install mine: https://github.com/cristianovitorino/snapd-bug-report/blob/master/ARCH-LINUX-INSTALL-GUIDE.md

Fedora

Just install vanilla Fedora Workstation 31.


That’s all.

Thanks again @hellsworth for trying to help and pointing me in the right direction.

You can reach me on:

  • Glimpse Matrix channel
  • [GitHub](https://github.com/cristianovitorino)
  • [Dribbble](https://dribbble.com/cristianovitorino)
  • [Twitter](https://twitter.com/cristvit)

Regards,
Cristiano Vitorino

Do you have a log maybe?

Edit: since I maintain the AUR package I normally build & install locally and in chroot. Tried yay this time after pushing the update, and did not see anything unusual.

@mborzecki

Do you have a log maybe?

Not anymore, no.

Edit: since I maintain the AUR package I normally build & install locally and in chroot. Tried yay this time after pushing the update, and did not see anything unusual.

Istalling with yay works fine now, provided that I follow the instructions I posted above. Everything else is still broken as described on the post.

The steps with snapd.seeded.service are not required and they do not fix the problem. The problem is fixed only by accident as the snapd.seeded.service activates snapd. You definitely do not need to enable or start snapd.seeded.service.

The issue is that on a clean install the first thing snapd does is initialize the system information. If you happen to do a request, such as trying to install a snap, you will get that too early for operation error. There’s a bunch of topic that raised this. We’ll probably have to address the message to make more sense.

I’m actually considering removing the snapd.seeded.service, because it’s not useful unless you build a system that seeds snaps on the first boot and need to wait for those to become available. I don’t really see anyone doing this with Arch.

So, we had a TU come and complain that the snapd.install package hook is doing too muc. So right now, it does as much as any other package shipping services which is basically nothing.

TBH, despite using Arch for 10+ years I still find some Arch Way things silly.

There is definitely no need to reboot. Unless there’s some very specific error you see, then please share, a log is fine.

What theme are you using? Is it listed here: https://gitlab.gnome.org/Community/Ubuntu/gtk-common-themes/-/blob/master/snap/snapcraft.yaml#L80 ?

The fonts are known problem. I’ve started investigating this in another topic, but didn’t have time to write a parser for fontconfig cache files to debug this in depth.

I see. But it does helps currently as a user first time installing it and not understanding what’s going on. It prevents seeing such message, specially if something goes wrong and the process hangs forever, like it happened to me, not letting you install anything.

Why not activate snapd before the user tries to do a request? The user gets confused with that frustrating message. And depending of how you installed it, the error can hang and you get stuck not being able to install anything, like it happened to me once, hance the safety process I described to be able to successfully install snapd fearing the risk of getting stuck again.

I don’t remember why. I have no logs as I was extremely frustrated and purged everything that had to do with snapd from my system as it was breaking stuff, like my .Xmodmap. All I did was to install snapd following official instructions and .Xmodmap was dead and I could barely use my keyboard, I didn’t do anything special.

About the logs, not a logical decision for sure, purely emotional, should have saved logs, but about six hours into it clouds your mind and mess with your emotions, I was still thinking “next time it will just works, I must be doing something wrong, I’ll follow it again, pay extra attention” and it never did.

I don’t have anything too exoctic in my Arch install, just vanilla Arch wiki install + GNOME + i3-gaps. I do sanitary and safety measures so I can keep the system stable and ready to redo some process/retest some application.

I would have to go through the process all over again to give you even more in depth information. And I don’t have the time at the moment, sorry about that, that’s all I can dedicate my time to report for now.

There are a ton of posts reporting these, for years, and I provided links to those. And it definitely should’t mess with .Xmodmap. This is extremely bizarre, I never seen an application mess up .Xmodmap before, so weird.

No, it’s not listed there. I use Vimix (Dark).

Sorry that I’m unable to be more useful, wish I had the time, to try again, to do a lot of logging, etc but I have my hands full already and the frustration from the process took a toll. I suggest that you guys look into the links I provided, I’m not alone having these bugs, they’re around for years for those that are not using vanilla Ubuntu. I remember these from a while back from Fedora 30 and 31. I just uninstalled it and went with Flathub instead at the time. There are more links out there, those are the ones I had the time to register, while trying to fix the problem.