Snapcraft with plugin Flutter suddenly crashing

I got my program to work and I rebuilt the snap (without any changes as far as I recall) and now the process is crashing

snapcraft.yaml

name: cybear-jinni
version: '1.0'
summary: App to control your smart device through CyBear Jinni Hub
description: Single app to control smart device from different form factor through CyBear Jinni Hub

grade: stable  # devel/stable, must be 'stable' to release into candidate/stable channels
confinement: strict  # devmode/classic/strict, use 'strict' once you have the right plugs and slots


base: core18

architectures:
  - build-on: amd64
  - build-on: arm64

parts:
  cybear-jinni:
    plugin: flutter
    source: https://github.com/CyBear-Jinni/CBJ_App.git
    flutter-target: lib/main.dart
    override-build: |
      flutter clean
      flutter pub get
      flutter pub run build_runner build --delete-conflicting-outputs
      snapcraftctl build

apps:
  cybear-jinni:
    command: CyBear-Jinni_App
    extensions: [flutter-master]
    plugs: [network, network-bind, network-manager, desktop-legacy, unity7]

The crash:

[ +230 ms] 💪 Building with sound null safety 💪
[  +58 ms] Building Linux application...
[  +29 ms] executing: [build/linux/x64/release/] cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DFLUTTER_TARGET_PLATFORM=linux-x64 /build/cybear-jinni/parts/cybear-jinni/build/linux
[+3564 ms] -- The CXX compiler identification is Clang 6.0.0
[  +35 ms] -- Check for working CXX compiler: /snap/flutter/current/usr/bin/clang++
[ +881 ms] -- Check for working CXX compiler: /snap/flutter/current/usr/bin/clang++ -- works
[   +6 ms] -- Detecting CXX compiler ABI info
[ +618 ms] -- Detecting CXX compiler ABI info - done
[  +13 ms] -- Detecting CXX compile features
[19/Aug/2021:10:07:58 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 12440322 "-" "Dart/2.15 (dart:io)"
[+3464 ms] -- Detecting CXX compile features - done
[  +75 ms] -- Found PkgConfig: /snap/flutter/current/usr/bin/pkg-config (found version "0.29.1") 
[        ] -- Checking for module 'gtk+-3.0'
[ +282 ms] --   Found gtk+-3.0, version 3.22.30
[+1062 ms] -- Checking for module 'glib-2.0'
[19/Aug/2021:10:08:02 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 9160280 "-" "Dart/2.15 (dart:io)"
[ +376 ms] --   Found glib-2.0, version 2.56.4
[ +651 ms] -- Checking for module 'gio-2.0'
[ +232 ms] --   Found gio-2.0, version 2.56.4
[ +657 ms] -- Configuring done
[ +240 ms] -- Generating done
[   +2 ms] -- Build files have been written to: /build/cybear-jinni/parts/cybear-jinni/build/build/linux/x64/release
[  +30 ms] executing: ninja -C build/linux/x64/release install
[  +47 ms] ninja: Entering directory `build/linux/x64/release'
[19/Aug/2021:10:08:04 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 7617265 "-" "Dart/2.15 (dart:io)"
[+77712 ms] [1/6] Generating /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/libflutter_linux_gtk.so, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_basic_message_channel.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_messenger.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_dart_project.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_engine.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_call.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_channel.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_response.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registrar.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registry.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_string_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_value.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_view.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/flutter_linux.h, _phony_
[  +34 ms] FAILED: /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/libflutter_linux_gtk.so /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_basic_message_channel.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_messenger.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_dart_project.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_engine.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_call.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_channel.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_response.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registrar.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registry.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_string_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_value.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_view.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/flutter_linux.h flutter/_phony_ 
[  +27 ms] cd /build/cybear-jinni/parts/cybear-jinni/build/build/linux/x64/release/flutter && /snap/flutter/101/usr/bin/cmake -E env FLUTTER_ROOT=/root/snap/flutter/common/flutter PROJECT_DIR=/build/cybear-jinni/parts/cybear-jinni/build DART_OBFUSCATION=false TRACK_WIDGET_CREATION=true TREE_SHAKE_ICONS=true PACKAGE_CONFIG=/build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config.json FLUTTER_TARGET=lib/main.dart /root/snap/flutter/common/flutter/packages/flutter_tools/bin/tool_backend.sh linux-x64 Release
[        ]    Woah! You appear to be trying to run flutter as root.
[        ]    We strongly recommend running the flutter tool without superuser privileges.
[        ]   /
[   +9 ms] 📎
[        ] [ +264 ms] executing: uname -m
[        ] [ +110 ms] Exit code 0 from: uname -m
[        ] [  +11 ms] x86_64
[        ] [  +20 ms] executing: [/root/snap/flutter/common/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] [  +26 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] [   +1 ms] ff547a9234287b6b06cf86b933161af32c3de410
[        ] [   +7 ms] executing: [/root/snap/flutter/common/flutter/] git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[        ] [  +54 ms] Exit code 0 from: git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[        ] [   +2 ms] executing: [/root/snap/flutter/common/flutter/] git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[        ] [  +91 ms] Exit code 0 from: git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[        ] [        ] 2.5.0-6.0.pre-155-gff547a9234
[        ] [  +19 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[        ] [  +25 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] [   +1 ms] origin/master
[        ] [   +1 ms] executing: [/root/snap/flutter/common/flutter/] git ls-remote --get-url origin
[        ] [  +23 ms] Exit code 0 from: git ls-remote --get-url origin
[        ] [   +1 ms] https://github.com/flutter/flutter.git
[        ] [ +173 ms] Unable to locate an Android SDK.
[        ] [  +15 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref HEAD
[        ] [  +31 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] [   +1 ms] master
[        ] [ +177 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [   +3 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [  +11 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[        ] [   +2 ms] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] [   +2 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +6 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] [ +380 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update.
[        ] [  +18 ms] Artifact Instance of 'GradleWrapper' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] [  +20 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +7 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[  +12 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[        ] [  +74 ms] Initializing file store
[        ] [  +76 ms] Skipping target: gen_localizations
[        ] [ +148 ms] gen_dart_plugin_registrant: Starting due to {InvalidatedReasonKind.inputChanged: The following inputs have updated contents: /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config_subset}
[        ] [  +31 ms] unpack_linux: Starting due to {}
[        ] [ +315 ms] unpack_linux: Complete
[        ] [ +888 ms] Found plugin connectivity_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus-1.0.7/
[        ] [  +19 ms] Found plugin connectivity_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_linux-1.0.3/
[        ] [   +8 ms] Found plugin connectivity_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_macos-1.0.2/
[        ] [  +17 ms] Found plugin connectivity_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_web-1.0.2/
[        ] [   +6 ms] Found plugin connectivity_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_windows-1.0.2/
[        ] [  +53 ms] Found plugin device_info at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/device_info-2.0.2/
[        ] [  +71 ms] Found plugin flutter_local_notifications at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_local_notifications-8.1.1+1/
[   +1 ms] [  +40 ms] Found plugin flutter_native_timezone at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_native_timezone-2.0.0/
[        ] [   +3 ms] Found plugin fluttertoast at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/fluttertoast-8.0.8/
[        ] [  +77 ms] Found plugin hexcolor at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/hexcolor-2.0.5/
[        ] [  +61 ms] Found plugin location at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/
[        ] [   +5 ms] Found plugin location_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location_web-3.1.1/
[        ] [  +58 ms] Found plugin network_info_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus-1.1.0/
[        ] [   +2 ms] Found plugin network_info_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_linux-1.0.2/
[        ] [  +14 ms] Found plugin network_info_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_macos-1.0.1/
[        ] [+31635 ms] /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/auto_route-2.3.0/lib/src/router/widgets/auto_router_delegate.dart:43:43: Error: Required named parameter 'type' must be provided.
[        ] [   +4 ms] Found plugin network_info_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_web-1.0.1/
[        ] [   +2 ms] Found plugin network_info_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_windows-1.0.2/
[        ] [   +3 ms] Found plugin path_provider at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-2.0.2/
[        ] [  +11 ms] Found plugin path_provider_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_linux-2.0.2/
[        ] [   +3 ms] Found plugin path_provider_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_macos-2.0.2/
[        ] [   +2 ms] Found plugin path_provider_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_windows-2.0.3/
[        ] [   +6 ms] Found plugin permission_handler at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-8.1.4+2/
[        ] [  +30 ms] Found plugin shared_preferences at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.6/
[        ] [   +2 ms] Found plugin shared_preferences_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_linux-2.0.2/
[        ] [   +1 ms] Found plugin shared_preferences_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_macos-2.0.2/
[        ] [   +1 ms] Found plugin shared_preferences_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_web-2.0.1/
[        ] [   +1 ms] Found plugin shared_preferences_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_windows-2.0.2/
[        ] [  +40 ms] Found plugin wifi_iot at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/wifi_iot-0.3.4/
[        ] [ +156 ms] gen_dart_plugin_registrant: Complete
[        ] [  +21 ms] kernel_snapshot: Starting due to {}
[   +1 ms] [  +39 ms] /root/snap/flutter/common/flutter/bin/cache/dart-sdk/bin/dart --disable-dart-dev /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64/frontend_server.dart.snapshot --sdk-root /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/common/flutter_patched_sdk_product/ --target=flutter --no-print-incremental-dependencies -Ddart.vm.profile=false -Ddart.vm.product=true --aot --tfa --packages /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config.json --output-dill /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/2016a524514f1387d0981c4ae56eddfd/app.dill --depfile /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/2016a524514f1387d0981c4ae56eddfd/kernel_snapshot.d /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/generated_main.dart
[   +2 ms] [   +3 ms]         ?.routerReportsNewRouteInformation(
[        ] [        ]                                           ^
[        ] [+39919 ms] Persisting file store
[        ] [  +26 ms] Done persisting file store
[        ] [  +24 ms] Target kernel_snapshot failed: Exception
[        ]            #0      KernelSnapshot.build (package:flutter_tools/src/build_system/targets/common.dart:229:7)
[        ]            <asynchronous suspension>
[        ]            #1      _BuildInstance._invokeInternal (package:flutter_tools/src/build_system/build_system.dart:836:9)
[        ]            <asynchronous suspension>
[        ]            #2      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #3      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #4      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #5      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #6      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #7      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #8      FlutterBuildSystem.build (package:flutter_tools/src/build_system/build_system.dart:603:16)
[        ]            <asynchronous suspension>
[        ]            #9      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:314:32)
[        ]            <asynchronous suspension>
[        ]            #10     FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
[   +5 ms]            <asynchronous suspension>
[   +1 ms]            #11     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[   +5 ms]            #12     CommandRunner.runCommand (package:args/command_runner.dart:209:13)
[        ]            <asynchronous suspension>
[        ]            #13     FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
[        ]            <asynchronous suspension>
[        ]            #14     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #15     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
[        ]            <asynchronous suspension>
[        ]            #16     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[        ]            <asynchronous suspension>
[        ]            #17     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #18     main (package:flutter_tools/executable.dart:92:3)
[        ]            <asynchronous suspension>
[        ] [  +37 ms] "flutter assemble" took 74,495ms.
[        ] [  +33 ms] 
[        ]            #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
[        ]            #1      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:331:7)
[        ]            <asynchronous suspension>
[        ]            #2      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
[        ]            <asynchronous suspension>
[        ]            #3      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #4      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
[        ]            <asynchronous suspension>
[        ]            #5      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
[        ]            <asynchronous suspension>
[        ]            #6      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #7      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
[        ]            <asynchronous suspension>
[        ]            #8      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[        ]            <asynchronous suspension>
[        ]            #9      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #10     main (package:flutter_tools/executable.dart:92:3)
[        ]            <asynchronous suspension>
[        ] [  +13 ms] ensureAnalyticsSent: 8ms
[        ] [   +3 ms] Running shutdown hooks
[        ] [   +2 ms] Shutdown hooks complete
[        ] [   +2 ms] exiting with code 1
[        ] ninja: build stopped: subcommand failed.
[  +40 ms] Building Linux application... (completed in 90.2s)
[   +5 ms] "flutter linux" took 107,584ms.
[  +16 ms] Build process failed
[        ] 
           #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
           #1      _runBuild (package:flutter_tools/src/linux/build_linux.dart:185:5)
           <asynchronous suspension>
           #2      buildLinux (package:flutter_tools/src/linux/build_linux.dart:77:5)
           <asynchronous suspension>
           #3      BuildLinuxCommand.runCommand (package:flutter_tools/src/commands/build_linux.dart:88:5)
           <asynchronous suspension>
           #4      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
           <asynchronous suspension>
           #5      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #6      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #9      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #10     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #11     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #12     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>


[  +11 ms] ensureAnalyticsSent: 6ms
[  +18 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1
flutter pub get
flutter build linux --release -v -t lib/main.dart
Failed to run 'flutter build linux --release -v -t lib/main.dart' for 'cybear-jinni': Exited with code 1.
Verify that the part is using the correct parameters and try again.
Build failed
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 231, in run
    self.build()
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 220, in build
    env=env)
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 100, in run_build_command
    return self.backend.run(args, env=full_env, **kwargs)
  File "/usr/lib/python3/dist-packages/lpbuildd/target/lxd.py", line 537, in run
    subprocess.check_call(cmd, **kwargs)
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['lxc', 'exec', 'lp-bionic-amd64', '--env', 'LANG=C.UTF-8', '--env', 'SHELL=/bin/sh', '--env', 'SNAPCRAFT_BUILD_INFO=1', '--env', 'SNAPCRAFT_IMAGE_INFO={"build-request-id": "lp-65549698", "build-request-timestamp": "2021-08-19T09:45:38Z", "build_url": "https://launchpad.net/~build.snapcraft.io/+snap/a49962441bf969e139d2944fe1e91c08/+build/1498342"}', '--env', 'SNAPCRAFT_BUILD_ENVIRONMENT=host', '--env', 'http_proxy=http://10.10.10.1:8222/', '--env', 'https_proxy=http://10.10.10.1:8222/', '--env', 'GIT_PROXY_COMMAND=/usr/local/bin/snap-git-proxy', '--', '/bin/sh', '-c', 'cd /build/cybear-jinni && linux64 snapcraft']' returned non-zero exit status 2.
Revoking proxy token...
RUN: /usr/share/launchpad-buildd/bin/in-target scan-for-processes --backend=lxd --series=bionic --arch=amd64 SNAPBUILD-1498342
Scanning for processes to kill in build SNAPBUILD-1498342

Little bit more of the build Log:

FINE: Extracted .tar.gz to /root/snap/flutter/common/flutter/.pub-cache/_temp/dirBSSWIX.
IO  : Renaming directory /root/snap/flutter/common/flutter/.pub-cache/_temp/dirBSSWIX to /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/win32-2.2.5.
IO  : Deleting directory /tmp/pub_OMKQWM.
ERR : Connection closed while receiving data
FINE: Exception type: ClientException
FINE: package:http/src/io_client.dart 54:13                               IOClient.send.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                          Stream.pipe
    | package:pub/src/http.dart 389:31                                    _ThrottleClient.send
    | ===== asynchronous gap ===========================
    | dart:async                                                          _asyncThenWrapperHelper
    | package:pub/src/source/hosted.dart 637:39                           BoundHostedSource._download.<fn>
    | package:pub/src/source/hosted.dart 634:23                           BoundHostedSource._download.<fn>
    | package:pub/src/io.dart 799:20                                      withTempDir
    | ===== asynchronous gap ===========================
    | dart:async                                                          _asyncThenWrapperHelper
    | package:pub/src/source/hosted.dart 634:11                           BoundHostedSource._download
    | ===== asynchronous gap ===========================
    | dart:async                                                          _asyncThenWrapperHelper
    | package:pub/src/source/hosted.dart 478:13                           BoundHostedSource.downloadToSystemCache
    | package:pub/src/entrypoint.dart 451:48                              Entrypoint._get.<fn>
    | package:pub/src/entrypoint.dart 447:9                               Entrypoint._get.<fn>
    | dart:async                                                          runZoned
    | package:pub/src/http.dart 296:10                                    withDependencyType
    | package:pub/src/entrypoint.dart 446:23                              Entrypoint._get
    | dart:async                                                          Future.wait
    | package:pub/src/entrypoint.dart 269:20                              Entrypoint.acquireDependencies
    | ===== asynchronous gap ===========================
    | dart:async                                                          _asyncThenWrapperHelper
    | package:pub/src/command/get.dart 48:23                              GetCommand.runProtected
    | dart:async                                                          new Future.sync
    | package:pub/src/utils.dart 112:12                                   captureErrors.wrappedCallback
    | package:stack_trace                                                 Chain.capture
    | package:pub/src/utils.dart 125:11                                   captureErrors
    | package:pub/src/command.dart 168:13                                 PubCommand.run
    | package:args/command_runner.dart 209:27                             CommandRunner.runCommand
    | package:pub/src/command_runner.dart 166:24                          PubCommandRunner.runCommand
    | package:pub/src/command_runner.dart 151:20                          PubCommandRunner.run
    | /b/s/w/ir/cache/builder/sdk/third_party/pkg/pub/bin/pub.dart 11:48  main
---- End log transcript ----
pub get failed (server unavailable) -- attempting retry 1 in 1 second...
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6174 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6052 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5953 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7459 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6987 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6492 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7056 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8014 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7678 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:28 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9774 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9532 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5835 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10377 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6165 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8515 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:29 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6519 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7342 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6251 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7888 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 13879 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7739 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6351 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7736 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6432 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6485 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6341 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10237 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6538 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6316 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10457 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5647 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8295 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:31 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6107 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6405 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8564 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8797 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5575 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9222 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8442 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 11201 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7431 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9324 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6110 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:32 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7956 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7464 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9386 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 15858 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7014 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7212 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6461 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6027 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7420 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8931 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6353 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8703 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7478 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10097 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6266 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6063 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6194 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:33 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5923 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6074 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 18960 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6028 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10047 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 11985 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5802 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6147 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5645 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 12727 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 11080 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5845 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7389 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:34 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6168 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7668 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8360 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6237 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6291 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6300 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7408 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6956 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10069 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6787 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6618 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5977 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8130 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7258 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6349 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7970 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:35 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8415 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7524 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7035 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6452 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6946 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5896 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7101 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6062 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6162 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6041 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9366 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9696 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6018 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6189 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5996 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5983 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5906 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6213 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6011 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6756 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6401 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5752 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6197 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6327 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5804 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6388 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:37 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6389 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:38 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8201 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:38 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7325 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:38 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10265 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:38 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8765 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:38 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10437 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6110 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5819 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6624 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6634 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6379 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:39 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6261 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9917 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7052 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7584 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6646 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6560 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:40 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6683 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9628 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6722 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6685 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5950 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6755 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8442 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6085 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8865 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6324 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5845 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6235 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6208 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6582 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:41 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6792 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 6326 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 8300 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7623 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7799 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 9202 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 10241 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:42 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 7405 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:44 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5089 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:44 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5096 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:44 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 5085 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:49 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 10981761 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:49 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 2962847 "-" "Dart/2.15 (dart:io)"
[19/Aug/2021:10:01:49 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 10827698 "-" "Dart/2.15 (dart:io)"
Running "flutter pub get" in build...                             174.8s
+ flutter pub run build_runner build --delete-conflicting-outputs
   Woah! You appear to be trying to run flutter as root.
   We strongly recommend running the flutter tool without superuser privileges.
  /
📎
[INFO] Generating build script...
[INFO] Generating build script completed, took 3.2s

[INFO] Precompiling build script......
[INFO] Precompiling build script... completed, took 35.9s

[INFO] Initializing inputs
[INFO] Building new asset graph...
[INFO] Building new asset graph completed, took 5.9s

[INFO] Checking for unexpected pre-existing outputs....
[INFO] Deleting 5 declared outputs which already existed on disk.
[INFO] Checking for unexpected pre-existing outputs. completed, took 55ms

[INFO] Running build...
[INFO] Generating SDK summary...
[19/Aug/2021:10:03:36 +0000] "CONNECT pub.dartlang.org:443 HTTP/1.1" 200 4660 "-" "Dart/2.15 (dart:io)"
[INFO] 17.2s elapsed, 0/16 actions completed.
[WARNING] No actions completed for 17.1s, waiting on:
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/home_user/home_user_dtos.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/home_user/home_user_repository.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/generic_devices/abstract_device/device_entity_dto_abstract.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/generic_devices/generic_light_device/generic_light_device_dtos.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/add_user_to_home/add_user_to_home_reposityory.dart
  .. and 11 more

[WARNING] auto_route_generator:autoRouteGenerator on lib/infrastructure/home_user/home_user_dtos.dart:
Your current `analyzer` version may not fully support your current SDK version.

Analyzer language version: 2.14.0
SDK language version: 2.15.0

Please ensure you are on the latest `analyzer` version, which can be seen at
https://pub.dev/packages/analyzer.

[INFO] Generating SDK summary completed, took 17.0s

[INFO] 18.7s elapsed, 8/16 actions completed.
[INFO] 19.7s elapsed, 16/32 actions completed.
[INFO] 20.7s elapsed, 19/35 actions completed.
[INFO] 21.8s elapsed, 20/36 actions completed.
[INFO] 22.9s elapsed, 21/36 actions completed.
[INFO] 24.0s elapsed, 21/37 actions completed.
[INFO] 25.2s elapsed, 21/37 actions completed.
[INFO] 26.3s elapsed, 21/37 actions completed.
[INFO] 27.3s elapsed, 21/37 actions completed.
[INFO] 28.7s elapsed, 22/38 actions completed.
[INFO] 29.7s elapsed, 23/39 actions completed.
[INFO] 30.7s elapsed, 23/39 actions completed.
[INFO] 31.8s elapsed, 23/39 actions completed.
[INFO] 32.8s elapsed, 24/40 actions completed.
[INFO] 33.9s elapsed, 24/40 actions completed.
[INFO] 34.9s elapsed, 24/40 actions completed.
[INFO] 36.1s elapsed, 24/40 actions completed.
[INFO] 37.4s elapsed, 24/40 actions completed.
[INFO] 38.5s elapsed, 25/40 actions completed.
[INFO] 39.5s elapsed, 25/41 actions completed.
[INFO] 40.6s elapsed, 25/41 actions completed.
[INFO] 41.6s elapsed, 25/41 actions completed.
[INFO] 46.8s elapsed, 25/41 actions completed.
[INFO] 47.9s elapsed, 25/41 actions completed.
[INFO] 49.0s elapsed, 26/42 actions completed.
[INFO] 50.0s elapsed, 27/43 actions completed.
[INFO] 51.0s elapsed, 27/43 actions completed.
[INFO] 52.1s elapsed, 27/43 actions completed.
[INFO] 53.2s elapsed, 27/43 actions completed.
[INFO] 56.1s elapsed, 27/43 actions completed.
[INFO] 59.0s elapsed, 29/45 actions completed.
[INFO] 1m 31s elapsed, 34/50 actions completed.
[WARNING] No actions completed for 32.1s, waiting on:
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/add_user_to_home/add_user_to_home_reposityory.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/folders_of_scenes/folders_of_scenes_repository.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/cbj_comp/cbj_comp_repository.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/hub_connection/hub_connection_repository.dart
  - auto_route_generator:autoRouteGenerator on lib/infrastructure/create_home/create_home_repository.dart
  .. and 11 more

[INFO] 1m 32s elapsed, 48/62 actions completed.
[INFO] 1m 33s elapsed, 85/100 actions completed.
[INFO] 1m 35s elapsed, 116/131 actions completed.
[INFO] 1m 36s elapsed, 128/142 actions completed.
[INFO] 1m 37s elapsed, 148/164 actions completed.
[INFO] 1m 38s elapsed, 149/165 actions completed.
[INFO] 1m 39s elapsed, 150/166 actions completed.
[INFO] 1m 41s elapsed, 152/167 actions completed.
[INFO] 1m 43s elapsed, 156/172 actions completed.
[INFO] 1m 45s elapsed, 158/173 actions completed.
[INFO] 1m 48s elapsed, 163/179 actions completed.
[INFO] 1m 51s elapsed, 182/198 actions completed.
[INFO] 1m 52s elapsed, 207/222 actions completed.
[INFO] 1m 56s elapsed, 218/234 actions completed.
[INFO] 1m 57s elapsed, 257/272 actions completed.
[INFO] 1m 58s elapsed, 293/308 actions completed.
[INFO] 1m 59s elapsed, 322/324 actions completed.
[WARNING] freezed:freezed on lib/infrastructure/home_user/home_user_dtos.dart:
The class HomeUserDtos was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/infrastructure/generic_devices/generic_light_device/generic_light_device_dtos.dart:
The class GenericLightDeviceDtos was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[INFO] 2m 2s elapsed, 347/362 actions completed.
[INFO] 2m 3s elapsed, 468/481 actions completed.
[WARNING] freezed:freezed on lib/infrastructure/create_home/create_home_dtos.dart:
The class CreateHomeDtos was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/infrastructure/user/user_dtos.dart:
The class UserDtos was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/infrastructure/user/all_homes_of_user_entity/all_homes_of_user_dtos.dart:
The class AllHomesOfUserDtos was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/domain/home_user/home_user_entity.dart:
The class HomeUserEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/domain/hub/hub_entity.dart:
The class HubEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/domain/cbj_comp/cbj_comp_entity.dart:
The class CBJCompEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[INFO] 2m 7s elapsed, 544/559 actions completed.
[INFO] 2m 8s elapsed, 561/577 actions completed.
[WARNING] freezed:freezed on lib/domain/manage_network/manage_network_entity.dart:
The class ManageNetworkEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/domain/user/all_homes_of_user/all_homes_of_user_entity.dart:
The class AllHomesOfUserEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[WARNING] freezed:freezed on lib/domain/user/user_entity.dart:
The class UserEntity was declared as abstract, but it is not need anymore.
Read here: https://github.com/rrousselGit/freezed/tree/master/packages/freezed#the-abstract-keyword

[INFO] 2m 10s elapsed, 609/625 actions completed.
[INFO] 2m 11s elapsed, 621/637 actions completed.
[INFO] 2m 12s elapsed, 635/649 actions completed.
[INFO] 2m 13s elapsed, 643/649 actions completed.
[INFO] 2m 14s elapsed, 669/685 actions completed.
[INFO] 2m 15s elapsed, 669/685 actions completed.
[INFO] 2m 16s elapsed, 676/692 actions completed.
[INFO] 2m 18s elapsed, 678/694 actions completed.
[INFO] 2m 19s elapsed, 791/805 actions completed.
[INFO] 2m 20s elapsed, 796/812 actions completed.
[INFO] 2m 21s elapsed, 798/813 actions completed.
[INFO] 2m 22s elapsed, 805/821 actions completed.
[INFO] 2m 25s elapsed, 815/831 actions completed.
[INFO] 2m 26s elapsed, 816/832 actions completed.
[INFO] 2m 27s elapsed, 821/837 actions completed.
[INFO] 2m 28s elapsed, 829/845 actions completed.
[INFO] 2m 29s elapsed, 841/856 actions completed.
[INFO] 2m 30s elapsed, 846/862 actions completed.
[INFO] 2m 31s elapsed, 851/867 actions completed.
[INFO] 2m 32s elapsed, 866/881 actions completed.
[INFO] 2m 34s elapsed, 873/888 actions completed.
[INFO] 2m 35s elapsed, 882/896 actions completed.
[INFO] 2m 36s elapsed, 887/902 actions completed.
[INFO] 2m 37s elapsed, 892/908 actions completed.
[INFO] 2m 38s elapsed, 900/916 actions completed.
[INFO] 2m 39s elapsed, 913/929 actions completed.
[INFO] 2m 40s elapsed, 922/938 actions completed.
[INFO] 2m 41s elapsed, 927/943 actions completed.
[INFO] 2m 42s elapsed, 934/950 actions completed.
[INFO] 2m 43s elapsed, 942/957 actions completed.
[INFO] 2m 44s elapsed, 953/968 actions completed.
[INFO] 2m 46s elapsed, 1022/1032 actions completed.
[INFO] 2m 47s elapsed, 1028/1032 actions completed.
[INFO] 2m 48s elapsed, 1040/1055 actions completed.
[INFO] 2m 49s elapsed, 1048/1063 actions completed.
[INFO] 2m 50s elapsed, 1060/1076 actions completed.
[INFO] 2m 51s elapsed, 1060/1076 actions completed.
[INFO] 2m 53s elapsed, 1068/1082 actions completed.
[INFO] 2m 54s elapsed, 1076/1092 actions completed.
[INFO] 2m 55s elapsed, 1084/1100 actions completed.
[INFO] 2m 56s elapsed, 1098/1114 actions completed.
[INFO] 2m 57s elapsed, 1108/1123 actions completed.
[INFO] 2m 58s elapsed, 1120/1135 actions completed.
[INFO] 2m 59s elapsed, 1131/1147 actions completed.
[INFO] 3m 0s elapsed, 1143/1158 actions completed.
[INFO] 3m 1s elapsed, 1157/1173 actions completed.
[INFO] 3m 2s elapsed, 1173/1188 actions completed.
[INFO] 3m 3s elapsed, 1222/1238 actions completed.
[INFO] 3m 4s elapsed, 1297/1310 actions completed.
[INFO] 3m 6s elapsed, 1403/1415 actions completed.
[INFO] 3m 7s elapsed, 1423/1431 actions completed.
[INFO] 3m 8s elapsed, 1472/1484 actions completed.
[WARNING] injectable_generator:injectable_config_builder on lib/injection.dart:
Missing dependencies in cybear_jinni/injection.dart

[AddUserToHomeRepository] depends on unregistered type [String] 

Did you forget to annotate the above class(s) or their implementation with @injectable?
------------------------------------------------------------------------ 

[INFO] 3m 10s elapsed, 1683/1697 actions completed.
[INFO] 3m 11s elapsed, 1822/1836 actions completed.
[INFO] 3m 12s elapsed, 1900/1914 actions completed.
[INFO] 3m 13s elapsed, 1961/1977 actions completed.
[INFO] 3m 15s elapsed, 2034/2049 actions completed.
[INFO] 3m 16s elapsed, 2076/2092 actions completed.
[INFO] 3m 17s elapsed, 2186/2202 actions completed.
[INFO] 3m 18s elapsed, 2222/2236 actions completed.
[INFO] 3m 19s elapsed, 2229/2245 actions completed.
[INFO] 3m 20s elapsed, 2245/2261 actions completed.
[INFO] 3m 21s elapsed, 2259/2274 actions completed.
[INFO] 3m 22s elapsed, 2271/2287 actions completed.
[INFO] 3m 23s elapsed, 2282/2296 actions completed.
[INFO] 3m 24s elapsed, 2290/2306 actions completed.
[INFO] 3m 25s elapsed, 2305/2320 actions completed.
[INFO] 3m 27s elapsed, 2315/2331 actions completed.
[INFO] 3m 28s elapsed, 2323/2339 actions completed.
[INFO] 3m 29s elapsed, 2374/2390 actions completed.
[INFO] 3m 30s elapsed, 2444/2458 actions completed.
[INFO] 3m 31s elapsed, 2558/2566 actions completed.
[INFO] 3m 32s elapsed, 2595/2598 actions completed.
[INFO] 3m 34s elapsed, 2633/2638 actions completed.
[INFO] 3m 35s elapsed, 2669/2674 actions completed.
[INFO] 3m 37s elapsed, 2702/2707 actions completed.
[INFO] 3m 38s elapsed, 2724/2729 actions completed.
[INFO] 3m 39s elapsed, 2746/2751 actions completed.
[INFO] 3m 41s elapsed, 2768/2773 actions completed.
[INFO] 3m 42s elapsed, 2803/2808 actions completed.
[INFO] 3m 43s elapsed, 2840/2845 actions completed.
[INFO] 3m 45s elapsed, 2876/2881 actions completed.
[INFO] 3m 46s elapsed, 2911/2916 actions completed.
[INFO] 3m 48s elapsed, 2933/2938 actions completed.
[INFO] 3m 49s elapsed, 2945/2950 actions completed.
[INFO] Running build completed, took 3m 49s

[INFO] Caching finalized dependency graph...
[INFO] 3m 51s elapsed, 2955/2955 actions completed.
[INFO] Caching finalized dependency graph completed, took 1.4s

[INFO] Succeeded after 3m 51s with 109 outputs (2955 actions)

+ snapcraftctl build
   Woah! You appear to be trying to run flutter as root.
   We strongly recommend running the flutter tool without superuser privileges.
  /
📎
Running "flutter pub get" in build...                               8.5s
   Woah! You appear to be trying to run flutter as root.
   We strongly recommend running the flutter tool without superuser privileges.
  /
📎
[ +170 ms] executing: uname -m
[  +76 ms] Exit code 0 from: uname -m
[   +2 ms] x86_64
[  +24 ms] executing: [/root/snap/flutter/common/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[  +34 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] ff547a9234287b6b06cf86b933161af32c3de410
[   +1 ms] executing: [/root/snap/flutter/common/flutter/] git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[  +37 ms] Exit code 0 from: git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[   +5 ms] executing: [/root/snap/flutter/common/flutter/] git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[  +79 ms] Exit code 0 from: git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[        ] 2.5.0-6.0.pre-155-gff547a9234
[  +29 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[  +27 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[   +3 ms] origin/master
[   +3 ms] executing: [/root/snap/flutter/common/flutter/] git ls-remote --get-url origin
[  +22 ms] Exit code 0 from: git ls-remote --get-url origin
[   +4 ms] https://github.com/flutter/flutter.git
[ +134 ms] Unable to locate an Android SDK.
[  +19 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref HEAD
[  +57 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] master
[ +141 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +8 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +3 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +162 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update.
[   +2 ms] Artifact Instance of 'GradleWrapper' is not required, skipping update.
[   +1 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +1 ms] Artifact Instance of 'FlutterSdk' is not required, skipping update.
[   +3 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[  +14 ms] Downloading linux-x64/linux-x64-flutter-gtk tools...
[ +577 ms] Content https://storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64/linux-x64-flutter-gtk.zip md5 hash: RLuP9E2xN7OlwZN1n/WsXA==
[+8324 ms] Downloading linux-x64/linux-x64-flutter-gtk tools... (completed in 8.9s)
[  +20 ms] executing: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64
[ +877 ms] Exit code 0 from: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64
[  +66 ms] Downloading linux-x64-profile/linux-x64-flutter-gtk tools...
[ +248 ms] Content https://storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-profile/linux-x64-flutter-gtk.zip md5 hash: gPAgdYWp3/GQKkHKOBgp9g==
[+2361 ms] Downloading linux-x64-profile/linux-x64-flutter-gtk tools... (completed in 2,605ms)
[   +1 ms] executing: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-profile/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64-profile
[ +667 ms] Exit code 0 from: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-profile/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64-profile
[  +39 ms] Downloading linux-x64-release/linux-x64-flutter-gtk tools...
[ +223 ms] Content https://storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-release/linux-x64-flutter-gtk.zip md5 hash: tUce9GVDZDzBrNIOF3xrWg==
[+1301 ms] Downloading linux-x64-release/linux-x64-flutter-gtk tools... (completed in 1,520ms)
[   +1 ms] executing: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-release/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64-release
[ +540 ms] Exit code 0 from: unzip -o -q /root/snap/flutter/common/flutter/bin/cache/downloads/storage.googleapis.com/flutter_infra_release/flutter/9a54e9e05c96f8f90aed6f46b4904bfe553df561/linux-x64-release/linux-x64-flutter-gtk.zip -d /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64-release
[  +58 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[   +1 ms] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[ +324 ms] Skipping pub get: version match.
[ +229 ms] Found plugin connectivity_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus-1.0.7/
[  +18 ms] Found plugin connectivity_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_linux-1.0.3/
[  +28 ms] Found plugin connectivity_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_macos-1.0.2/
[   +9 ms] Found plugin connectivity_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_web-1.0.2/
[   +3 ms] Found plugin connectivity_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_windows-1.0.2/
[  +14 ms] Found plugin device_info at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/device_info-2.0.2/
[  +50 ms] Found plugin flutter_local_notifications at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_local_notifications-8.1.1+1/
[   +8 ms] Found plugin flutter_native_timezone at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_native_timezone-2.0.0/
[   +4 ms] Found plugin fluttertoast at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/fluttertoast-8.0.8/
[  +25 ms] Found plugin hexcolor at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/hexcolor-2.0.5/
[  +52 ms] Found plugin location at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/
[   +7 ms] Found plugin location_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location_web-3.1.1/
[   +7 ms] Found plugin network_info_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus-1.1.0/
[   +2 ms] Found plugin network_info_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_linux-1.0.2/
[   +8 ms] Found plugin network_info_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_macos-1.0.1/
[   +2 ms] Found plugin network_info_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_web-1.0.1/
[   +2 ms] Found plugin network_info_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_windows-1.0.2/
[   +3 ms] Found plugin path_provider at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-2.0.2/
[   +5 ms] Found plugin path_provider_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_linux-2.0.2/
[   +7 ms] Found plugin path_provider_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_macos-2.0.2/
[   +2 ms] Found plugin path_provider_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_windows-2.0.3/
[  +10 ms] Found plugin permission_handler at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-8.1.4+2/
[  +20 ms] Found plugin shared_preferences at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.6/
[   +6 ms] Found plugin shared_preferences_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_linux-2.0.2/
[   +2 ms] Found plugin shared_preferences_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_macos-2.0.2/
[  +11 ms] Found plugin shared_preferences_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_web-2.0.1/
[   +8 ms] Found plugin shared_preferences_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_windows-2.0.2/
[  +31 ms] Found plugin wifi_iot at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/wifi_iot-0.3.4/
[ +405 ms] Found plugin connectivity_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus-1.0.7/
[   +7 ms] Found plugin connectivity_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_linux-1.0.3/
[   +2 ms] Found plugin connectivity_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_macos-1.0.2/
[   +7 ms] Found plugin connectivity_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_web-1.0.2/
[   +2 ms] Found plugin connectivity_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_windows-1.0.2/
[   +5 ms] Found plugin device_info at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/device_info-2.0.2/
[  +13 ms] Found plugin flutter_local_notifications at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_local_notifications-8.1.1+1/
[   +8 ms] Found plugin flutter_native_timezone at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_native_timezone-2.0.0/
[   +3 ms] Found plugin fluttertoast at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/fluttertoast-8.0.8/
[  +17 ms] Found plugin hexcolor at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/hexcolor-2.0.5/
[  +32 ms] Found plugin location at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/
[   +1 ms] Found plugin location_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location_web-3.1.1/
[  +18 ms] Found plugin network_info_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus-1.1.0/
[   +1 ms] Found plugin network_info_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_linux-1.0.2/
[        ] Found plugin network_info_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_macos-1.0.1/
[   +1 ms] Found plugin network_info_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_web-1.0.1/
[        ] Found plugin network_info_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_windows-1.0.2/
[   +1 ms] Found plugin path_provider at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-2.0.2/
[        ] Found plugin path_provider_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_linux-2.0.2/
[        ] Found plugin path_provider_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_macos-2.0.2/
[  +14 ms] Found plugin path_provider_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_windows-2.0.3/
[   +1 ms] Found plugin permission_handler at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-8.1.4+2/
[   +5 ms] Found plugin shared_preferences at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.6/
[        ] Found plugin shared_preferences_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_linux-2.0.2/
[        ] Found plugin shared_preferences_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_macos-2.0.2/
[   +1 ms] Found plugin shared_preferences_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_web-2.0.1/
[        ] Found plugin shared_preferences_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_windows-2.0.2/
[  +30 ms] Found plugin wifi_iot at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/wifi_iot-0.3.4/
[  +52 ms] Generating /build/cybear-jinni/parts/cybear-jinni/build/android/app/src/main/java/io/flutter/plugins/GeneratedPluginRegistrant.java
[ +230 ms] 💪 Building with sound null safety 💪
[  +58 ms] Building Linux application...
[  +29 ms] executing: [build/linux/x64/release/] cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DFLUTTER_TARGET_PLATFORM=linux-x64 /build/cybear-jinni/parts/cybear-jinni/build/linux
[+3564 ms] -- The CXX compiler identification is Clang 6.0.0
[  +35 ms] -- Check for working CXX compiler: /snap/flutter/current/usr/bin/clang++
[ +881 ms] -- Check for working CXX compiler: /snap/flutter/current/usr/bin/clang++ -- works
[   +6 ms] -- Detecting CXX compiler ABI info
[ +618 ms] -- Detecting CXX compiler ABI info - done
[  +13 ms] -- Detecting CXX compile features
[19/Aug/2021:10:07:58 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 12440322 "-" "Dart/2.15 (dart:io)"
[+3464 ms] -- Detecting CXX compile features - done
[  +75 ms] -- Found PkgConfig: /snap/flutter/current/usr/bin/pkg-config (found version "0.29.1") 
[        ] -- Checking for module 'gtk+-3.0'
[ +282 ms] --   Found gtk+-3.0, version 3.22.30
[+1062 ms] -- Checking for module 'glib-2.0'
[19/Aug/2021:10:08:02 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 9160280 "-" "Dart/2.15 (dart:io)"
[ +376 ms] --   Found glib-2.0, version 2.56.4
[ +651 ms] -- Checking for module 'gio-2.0'
[ +232 ms] --   Found gio-2.0, version 2.56.4
[ +657 ms] -- Configuring done
[ +240 ms] -- Generating done
[   +2 ms] -- Build files have been written to: /build/cybear-jinni/parts/cybear-jinni/build/build/linux/x64/release
[  +30 ms] executing: ninja -C build/linux/x64/release install
[  +47 ms] ninja: Entering directory `build/linux/x64/release'
[19/Aug/2021:10:08:04 +0000] "CONNECT storage.googleapis.com:443 HTTP/1.1" 200 7617265 "-" "Dart/2.15 (dart:io)"
[+77712 ms] [1/6] Generating /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/libflutter_linux_gtk.so, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_basic_message_channel.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_messenger.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_dart_project.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_engine.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_call.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_channel.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_response.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registrar.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registry.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_message_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_method_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_string_codec.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_value.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_view.h, /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/flutter_linux.h, _phony_
[  +34 ms] FAILED: /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/libflutter_linux_gtk.so /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_basic_message_channel.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_binary_messenger.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_dart_project.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_engine.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_json_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_call.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_channel.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_method_response.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registrar.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_plugin_registry.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_message_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_standard_method_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_string_codec.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_value.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/fl_view.h /build/cybear-jinni/parts/cybear-jinni/build/linux/flutter/ephemeral/flutter_linux/flutter_linux.h flutter/_phony_ 
[  +27 ms] cd /build/cybear-jinni/parts/cybear-jinni/build/build/linux/x64/release/flutter && /snap/flutter/101/usr/bin/cmake -E env FLUTTER_ROOT=/root/snap/flutter/common/flutter PROJECT_DIR=/build/cybear-jinni/parts/cybear-jinni/build DART_OBFUSCATION=false TRACK_WIDGET_CREATION=true TREE_SHAKE_ICONS=true PACKAGE_CONFIG=/build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config.json FLUTTER_TARGET=lib/main.dart /root/snap/flutter/common/flutter/packages/flutter_tools/bin/tool_backend.sh linux-x64 Release
[        ]    Woah! You appear to be trying to run flutter as root.
[        ]    We strongly recommend running the flutter tool without superuser privileges.
[        ]   /
[   +9 ms] 📎
[        ] [ +264 ms] executing: uname -m
[        ] [ +110 ms] Exit code 0 from: uname -m
[        ] [  +11 ms] x86_64
[        ] [  +20 ms] executing: [/root/snap/flutter/common/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] [  +26 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] [   +1 ms] ff547a9234287b6b06cf86b933161af32c3de410
[        ] [   +7 ms] executing: [/root/snap/flutter/common/flutter/] git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[        ] [  +54 ms] Exit code 0 from: git tag --points-at ff547a9234287b6b06cf86b933161af32c3de410
[        ] [   +2 ms] executing: [/root/snap/flutter/common/flutter/] git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[        ] [  +91 ms] Exit code 0 from: git describe --match *.*.* --long --tags ff547a9234287b6b06cf86b933161af32c3de410
[        ] [        ] 2.5.0-6.0.pre-155-gff547a9234
[        ] [  +19 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[        ] [  +25 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] [   +1 ms] origin/master
[        ] [   +1 ms] executing: [/root/snap/flutter/common/flutter/] git ls-remote --get-url origin
[        ] [  +23 ms] Exit code 0 from: git ls-remote --get-url origin
[        ] [   +1 ms] https://github.com/flutter/flutter.git
[        ] [ +173 ms] Unable to locate an Android SDK.
[        ] [  +15 ms] executing: [/root/snap/flutter/common/flutter/] git rev-parse --abbrev-ref HEAD
[        ] [  +31 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] [   +1 ms] master
[        ] [ +177 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [   +3 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [  +11 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[        ] [   +2 ms] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] [   +2 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +6 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] [ +380 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update.
[        ] [  +18 ms] Artifact Instance of 'GradleWrapper' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'WindowsUwpEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] [  +20 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +7 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[  +12 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[        ] [  +74 ms] Initializing file store
[        ] [  +76 ms] Skipping target: gen_localizations
[        ] [ +148 ms] gen_dart_plugin_registrant: Starting due to {InvalidatedReasonKind.inputChanged: The following inputs have updated contents: /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config_subset}
[        ] [  +31 ms] unpack_linux: Starting due to {}
[        ] [ +315 ms] unpack_linux: Complete
[        ] [ +888 ms] Found plugin connectivity_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus-1.0.7/
[        ] [  +19 ms] Found plugin connectivity_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_linux-1.0.3/
[        ] [   +8 ms] Found plugin connectivity_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_macos-1.0.2/
[        ] [  +17 ms] Found plugin connectivity_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_web-1.0.2/
[        ] [   +6 ms] Found plugin connectivity_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/connectivity_plus_windows-1.0.2/
[        ] [  +53 ms] Found plugin device_info at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/device_info-2.0.2/
[        ] [  +71 ms] Found plugin flutter_local_notifications at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_local_notifications-8.1.1+1/
[   +1 ms] [  +40 ms] Found plugin flutter_native_timezone at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_native_timezone-2.0.0/
[        ] [   +3 ms] Found plugin fluttertoast at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/fluttertoast-8.0.8/
[        ] [  +77 ms] Found plugin hexcolor at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/hexcolor-2.0.5/
[        ] [  +61 ms] Found plugin location at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/
[        ] [   +5 ms] Found plugin location_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/location_web-3.1.1/
[        ] [  +58 ms] Found plugin network_info_plus at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus-1.1.0/
[        ] [   +2 ms] Found plugin network_info_plus_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_linux-1.0.2/
[        ] [  +14 ms] Found plugin network_info_plus_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_macos-1.0.1/
[        ] [+31635 ms] /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/auto_route-2.3.0/lib/src/router/widgets/auto_router_delegate.dart:43:43: Error: Required named parameter 'type' must be provided.
[        ] [   +4 ms] Found plugin network_info_plus_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_web-1.0.1/
[        ] [   +2 ms] Found plugin network_info_plus_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/network_info_plus_windows-1.0.2/
[        ] [   +3 ms] Found plugin path_provider at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-2.0.2/
[        ] [  +11 ms] Found plugin path_provider_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_linux-2.0.2/
[        ] [   +3 ms] Found plugin path_provider_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_macos-2.0.2/
[        ] [   +2 ms] Found plugin path_provider_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider_windows-2.0.3/
[        ] [   +6 ms] Found plugin permission_handler at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-8.1.4+2/
[        ] [  +30 ms] Found plugin shared_preferences at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.6/
[        ] [   +2 ms] Found plugin shared_preferences_linux at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_linux-2.0.2/
[        ] [   +1 ms] Found plugin shared_preferences_macos at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_macos-2.0.2/
[        ] [   +1 ms] Found plugin shared_preferences_web at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_web-2.0.1/
[        ] [   +1 ms] Found plugin shared_preferences_windows at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences_windows-2.0.2/
[        ] [  +40 ms] Found plugin wifi_iot at /root/snap/flutter/common/flutter/.pub-cache/hosted/pub.dartlang.org/wifi_iot-0.3.4/
[        ] [ +156 ms] gen_dart_plugin_registrant: Complete
[        ] [  +21 ms] kernel_snapshot: Starting due to {}
[   +1 ms] [  +39 ms] /root/snap/flutter/common/flutter/bin/cache/dart-sdk/bin/dart --disable-dart-dev /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/linux-x64/frontend_server.dart.snapshot --sdk-root /root/snap/flutter/common/flutter/bin/cache/artifacts/engine/common/flutter_patched_sdk_product/ --target=flutter --no-print-incremental-dependencies -Ddart.vm.profile=false -Ddart.vm.product=true --aot --tfa --packages /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/package_config.json --output-dill /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/2016a524514f1387d0981c4ae56eddfd/app.dill --depfile /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/2016a524514f1387d0981c4ae56eddfd/kernel_snapshot.d /build/cybear-jinni/parts/cybear-jinni/build/.dart_tool/flutter_build/generated_main.dart
[   +2 ms] [   +3 ms]         ?.routerReportsNewRouteInformation(
[        ] [        ]                                           ^
[        ] [+39919 ms] Persisting file store
[        ] [  +26 ms] Done persisting file store
[        ] [  +24 ms] Target kernel_snapshot failed: Exception
[        ]            #0      KernelSnapshot.build (package:flutter_tools/src/build_system/targets/common.dart:229:7)
[        ]            <asynchronous suspension>
[        ]            #1      _BuildInstance._invokeInternal (package:flutter_tools/src/build_system/build_system.dart:836:9)
[        ]            <asynchronous suspension>
[        ]            #2      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #3      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #4      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #5      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #6      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #7      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:774:32)
[        ]            <asynchronous suspension>
[        ]            #8      FlutterBuildSystem.build (package:flutter_tools/src/build_system/build_system.dart:603:16)
[        ]            <asynchronous suspension>
[        ]            #9      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:314:32)
[        ]            <asynchronous suspension>
[        ]            #10     FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
[   +5 ms]            <asynchronous suspension>
[   +1 ms]            #11     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[   +5 ms]            #12     CommandRunner.runCommand (package:args/command_runner.dart:209:13)
[        ]            <asynchronous suspension>
[        ]            #13     FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
[        ]            <asynchronous suspension>
[        ]            #14     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #15     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
[        ]            <asynchronous suspension>
[        ]            #16     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[        ]            <asynchronous suspension>
[        ]            #17     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #18     main (package:flutter_tools/executable.dart:92:3)
[        ]            <asynchronous suspension>
[        ] [  +37 ms] "flutter assemble" took 74,495ms.
[        ] [  +33 ms] 
[        ]            #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
[        ]            #1      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:331:7)
[        ]            <asynchronous suspension>
[        ]            #2      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
[        ]            <asynchronous suspension>
[        ]            #3      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #4      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
[        ]            <asynchronous suspension>
[        ]            #5      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
[        ]            <asynchronous suspension>
[        ]            #6      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #7      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
[        ]            <asynchronous suspension>
[        ]            #8      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[        ]            <asynchronous suspension>
[        ]            #9      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[        ]            <asynchronous suspension>
[        ]            #10     main (package:flutter_tools/executable.dart:92:3)
[        ]            <asynchronous suspension>
[        ] [  +13 ms] ensureAnalyticsSent: 8ms
[        ] [   +3 ms] Running shutdown hooks
[        ] [   +2 ms] Shutdown hooks complete
[        ] [   +2 ms] exiting with code 1
[        ] ninja: build stopped: subcommand failed.
[  +40 ms] Building Linux application... (completed in 90.2s)
[   +5 ms] "flutter linux" took 107,584ms.
[  +16 ms] Build process failed
[        ] 
           #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
           #1      _runBuild (package:flutter_tools/src/linux/build_linux.dart:185:5)
           <asynchronous suspension>
           #2      buildLinux (package:flutter_tools/src/linux/build_linux.dart:77:5)
           <asynchronous suspension>
           #3      BuildLinuxCommand.runCommand (package:flutter_tools/src/commands/build_linux.dart:88:5)
           <asynchronous suspension>
           #4      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1125:27)
           <asynchronous suspension>
           #5      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #6      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #9      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #10     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #11     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #12     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>


[  +11 ms] ensureAnalyticsSent: 6ms
[  +18 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1
flutter pub get
flutter build linux --release -v -t lib/main.dart
Failed to run 'flutter build linux --release -v -t lib/main.dart' for 'cybear-jinni': Exited with code 1.
Verify that the part is using the correct parameters and try again.
Build failed
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 231, in run
    self.build()
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 220, in build
    env=env)
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 100, in run_build_command
    return self.backend.run(args, env=full_env, **kwargs)
  File "/usr/lib/python3/dist-packages/lpbuildd/target/lxd.py", line 537, in run
    subprocess.check_call(cmd, **kwargs)
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['lxc', 'exec', 'lp-bionic-amd64', '--env', 'LANG=C.UTF-8', '--env', 'SHELL=/bin/sh', '--env', 'SNAPCRAFT_BUILD_INFO=1', '--env', 'SNAPCRAFT_IMAGE_INFO={"build-request-id": "lp-65549698", "build-request-timestamp": "2021-08-19T09:45:38Z", "build_url": "https://launchpad.net/~build.snapcraft.io/+snap/a49962441bf969e139d2944fe1e91c08/+build/1498342"}', '--env', 'SNAPCRAFT_BUILD_ENVIRONMENT=host', '--env', 'http_proxy=http://10.10.10.1:8222/', '--env', 'https_proxy=http://10.10.10.1:8222/', '--env', 'GIT_PROXY_COMMAND=/usr/local/bin/snap-git-proxy', '--', '/bin/sh', '-c', 'cd /build/cybear-jinni && linux64 snapcraft']' returned non-zero exit status 2.
Revoking proxy token...
RUN: /usr/share/launchpad-buildd/bin/in-target scan-for-processes --backend=lxd --series=bionic --arch=amd64 SNAPBUILD-1498342
Scanning for processes to kill in build SNAPBUILD-1498342

Do you have anything in your local build directory? Perhaps clean that and try it. I often just rm -rf build in the project directory when i’ve been doing local builds, otherwise it copies some of those artifacts into the snapcraft build.

So I have tested it and… works only if.
If I run snapcraft --debug and after the crash I run rm -rf build and than flutter build linux --release -v -t lib/main.dart it will work.

Tested running rm -rf build in the override-build: after flutter pub run build_runner build --delete-conflicting-outputs and it is not working.

So the fix should probably be in way the plugin: flutter is working.

Strange that it started happening to me all of a sudden now, maybe snapcraft update?.

Found it, according to this post it is a bug in Flutter master branch.
It seems that I have changed to master from dev and I thought it will be more stable so I didn’t gave it a second thought :sweat_smile:.
My last comment shouldn’t work (it worked only once not sure why).

I have changed the extensions to stable extensions: [flutter-stable] and it works :partying_face:.

By the way (not related) my IDE (android sudio) doesn’t approve of stable, my guess is that the YAML plugin didn’t get it yet.

Now I have different error and I hope it is not related to this, if it does I will link here the new issue.

Thanks