Snapcraft using HTTP instead of HTTPS when building dotnet core snap

Hello, new to snapcraft so this may have an obvious answer. I’m trying to build a simple helloworld snap from a dotnet core console application with snapcraft.

When I run snapcraft I get the following error:
HTTP Error 400: The account being accessed does not support http.

So I ran tcpflow to see what was causing the error and I got the following:

tcpflow: listening on wlp3s0
192.168.088.129.50042-052.241.088.084.00080: GET /dotnet/release-metadata/2.0/releases.json HTTP/1.1
Accept-Encoding: identity
Host: dotnetcli.blob.core.windows.net
User-Agent: Python-urllib/3.6
Connection: close
052.241.088.084.00080-192.168.088.129.50042: HTTP/1.1 400 The account being accessed does not support http.
Content-Length: 274
Content-Type: application/xml
Server: Microsoft-HTTPAPI/2.0
x-ms-request-id: c1bd289d-b01e-0013-1c8a-519d2a000000
Date: Tue, 25 May 2021 17:18:51 GMT
Connection: close
<?xml version="1.0" encoding="utf-8"?><Error><Code>AccountRequiresHttps</Code><Message>The account being accessed does not support http.
RequestId:c1bd289d-b01e-0013-1c8a-519d2a000000
Time:2021-05-25T17:18:51.8534310Z</Message><AccountName>dotnetcli</AccountName></Error>
192.168.088.129.49246-035.232.111.017.00080: GET / HTTP/1.1
Host: connectivity-check.ubuntu.com
Accept: */*
Connection: close
035.232.111.017.00080-192.168.088.129.49246: HTTP/1.1 204 No Content
Date: Tue, 25 May 2021 17:23:31 GMT
Server: Apache/2.4.18 (Ubuntu)
X-NetworkManager-Status: online
Connection: close

So snapcraft is trying to download http://dotnetcli.blob.core.windows.net/dotnet/release-metadata/2.0/releases.json
but it should be using HTTPS instead of HTTP for this, and I’m using dotnet core v5 but that file is the metadata for v2. Here’s my snapcraft.yaml

name: testapp1 # you probably want to 'snapcraft register <name>'
base: core18 # the base snap is the execution environment for this snap
version: '0.1' # just for humans, typically '1.2+git' or '1.3.2'
summary: Single-line elevator pitch for your amazing snap # 79 char long summary
description: |
  This is my-snap's description. You have a paragraph or two to tell the
  most important story about your snap. Keep it under 100 words though,
  we live in tweetspace and your description wants to look good in the snap
  store.

grade: devel # must be 'stable' to release into candidate/stable channels
confinement: devmode # use 'strict' once you have the right plugs and slots

apps:
  testapp1:
    command: testapp1
      
parts:
  testapp1:
    # See 'snapcraft plugins'
    plugin: dotnet
    dotnet-version: 5.0
    dotnet-runtime-version: 5.0.3
    source: .

So I guess I’m either doing something wrong, or snapcraft is trying to access dotnetcore v2 instead of v5.

What do I need to do for snapcraft to use https during the build, and download the correct releases.json file?

System details are:
Ubuntu 18.04.5
Snapcraft v4.7.1 latest/stable classic
snap v2.50
snapd v2.50
dotnet-sdk snap v5.0.300 latest/stable
base: core18

can you try Snapcraft from edge? We have a planned start of release for that today.

Yeah, that worked. It got me past that error anyway, got a .NET error now but I can fix that myself.