`snapcraft` succeeds but automated build fails

I’m setting up automated build of the scelight snap. I had to write a custom plugin for gradle because the stock gradle plugin supports java jar and war tasks but not the java application task. The build succeeds when I run it locally and produces a snap that I can install and run just fine.

The first time I did an automated build with the plugin, I got the fail message:

Failed to load plugin: properties failed to load for scelight: 'source' is a required property
Build failed

even though `source was in snapcraft.yaml:

    plugin: gradle-application
    source: .

I tried restricting architectures to ia32 and amd64, and removing “source” from the required properties in the schema. After doing this, the automated build fails with error:

Could not find a required package in 'build-packages': openjdk-11-jdk-headless
Build failed

I’m not sure, bit it looks like the automated build system doesn’t honor base: core18 in snapcraft.yaml. Is there a way I can make automated builds work, or is this something that has to be fixed by the Snapcraft team?

Also, like every other snap, the scelight snap makes the cursor tiny when the cursor is on top of the app window. Is there a way I can fix this, or do I just need to wait for snap technology to support the normal cursor size?

Source code: https://github.com/dmiller309/scelight

1 Like

This is a duplicate of

It would be nice if there was an ETA for core18 snaps working with the automated snap build system.

1 Like