Snapcraft from cosmic repos causes frustrations


#1

Snapcraft in the Cosmic repository is version 2.43, while all the documentation now talks about snapcraft 3. This has caused a lot of frustration and confusion and I lost a lot of time over this. Please at least give a warning message that the cosmic package is outdated or deprecated.


#2

We generally recommend people install the snap of snapcraft. Is there some documentation you were following that suggested you use the deb from the repo?

We need to clear that up if there are indeed outdated docs.


#3

I think I have snapcraft installed since before the snap was even available. The tool should really warn users that the deb package is not recommended.

I, for instance, install many applications by just searching for it using apt search. We really can’t expect everyone to look up the tutorial for how to install Snapcraft.


#4

Yeah, perhaps the deb could grow a little warning prompt recommending use of the snap. I’m not sure what the long term plan for the deb is right now. @sergiusens will know :slight_smile:


#5

I wonder if Snapcraft 3 will be introduced to the ubuntu releases that originally ships Snapcraft 2.x?


#6

Well the documentation should mention both as long as the legacy syntax isn’t obsoleted.