Snapcraft does not recognize offline mode

I want to use the snapcraft offline mode. But the argument (–offline) did not get recognized. 2022-11-02_13h56_37

The version I used is Snapcraft V7.2.4

it would probably help to write the option with two f ?

Thanks for the hint. I updated my screenshot.

1 Like

did you also call snapcraft pull first ? (not sure that will change a thing regarding the missing option, but the doc above says this is a requirement to have everything cached first)

Yes, I did call snapcraft pull first.

It’s not just you - I’ve just tried both as well, with the same outcome. The offline option is unavailable with Snapcraft 7.2.3.

It still works with Snapcraft 6.x (snap refresh snapcraft --channel=6.x/stable), so this might be something lost in the new version. I’ll check with the Snapcraft team.


I’ve just spoken to the Snapcraft team and offline mode (which they reminded me was experimental anyway) has been dropped from Snapcraft 7.x, with the intention of re-engineering a better offline solution for the next generation of Snapcraft releases. There’s no current timeframe for this.

@nick.h; sorry this isn’t likely the answer you wanted to hear, but I’ll update the docs and keep on-top of any further developments.

1 Like

Hi @degville Are there any news on this topic? Is this feature scheduled for a Snapcraft release?