Snapcraft build server can't access

The snapcraft build server (what do we call it, now that it’s not any more?) seems to block or be blocked from Is that intentional? The url is correct and the server is online and accessible from everywhere else i’ve tried.

[02/Oct/2020:09:50:55 +0000] "GET HTTP/1.1" 200 57470 "-" "axios/0.20.0"
[02/Oct/2020:09:50:56 +0000] "GET HTTP/1.1" 302 96 "-" "axios/0.20.0"
Error: Error: Download Error: Error: getaddrinfo ENOTFOUND
    at /build/ubports-installer/parts/ubports-installer/build/node_modules/progressive-downloader/lib/module.cjs:222:14
    at process._tickCallback (internal/process/next_tick.js:68:7)

This is from build 1136447 from ubports-installer. I’ve tried multiple times yesterday and today.

… call it launchpad :wink: it is not much different to a PPA builder after all … (if you look at the top of your log you should see the LP url pointing to your actual build …)

there are security tokens for accessing the proxy during bullds, IIRC they time out after roughly 2h. if you have a part that takes a long time this can cause issues with internet access for later parts …

Nifty, thanks, i did not see that!

I don’t think that’s it, this particular build failed six minutes in.

well, try asking in #launchpad on freenode then … perhaps there are known issues with DNS resolution through the proxy or some such …

1 Like

Thanks for the hint. Can’t find my original freeenode credentials (yes, i know, this does not help my nerd credibility), so i opened a question on launchpad itself for now. something is definitely weird. I’ll leave this open for now, maybe someone here knows more. Will mark solved as soon as it is. Thanks again.

1 Like