Snap won't run vlc


#1

Hi. I installed Snap on my prehistoric laptop running Linux Mint 17.2 Rafaela. Then seemed to install vlc without any errors. Hoever when running:
$ snap run vlc
I got the following error:
cannot perform operation: mount --bind /snap/core/current//etc/nsswitch.conf /tmp/snap.rootfs_uhjqTW/etc/nsswitch.conf: Permission denied

What can I do to fix this please? Thanks.


#2

Hi @zarg, sorry to hear you’re having problems.
Could you please paste the output from the command snap version and snap info vlc. Thanks


#3

In addition to what @popey asked could you please add the output of:

ls -ld /etc/nsswitch.conf

#4

Thanks for the replies. I didn’t want you to think I was ignoring your kind help, but I won’t have access to the laptop until Wednesday 13th at the earliest so won’t be able to run those commands until then. I’ll get back to you as soon as possible. Thanks again.


#5

Hi Popey. output from snap version:
snap 2.37.1
snapd 2.37.1
series 16
ubuntu 14.04
kernel 3.16.0-38-generic

Output fromsnap info vlc:
name: vlc
summary: The ultimate media player
publisher: VideoLAN✓
contact: https://www.videolan.org/support/
license: unset
description: |
VLC is the VideoLAN project’s media player.

Completely open source and privacy-friendly, it plays every multimedia file
and streams.

It notably plays MKV, MP4, MPEG, MPEG-2, MPEG-4, DivX, MOV, WMV, QuickTime,
WebM, FLAC, MP3, Ogg/Vorbis files, BluRays, DVDs, VCDs, podcasts, and
multimedia streams from various network sources. It supports subtitles,
closed captions and is translated in numerous languages.
commands:

  • vlc
    snap-id: RT9mcUhVsRYrDLG8qnvGiy26NKvv6Qkd
    tracking: stable
    refresh-date: 6 days ago, at 15:47 GMT
    channels:
    stable: 3.0.6 2019-01-10 (770) 212MB -
    candidate: 3.0.6 2019-01-10 (770) 212MB -
    beta: 3.0.6-60-g488d9f4 2019-02-13 (836) 212MB -
    edge: 4.0.0-dev-6471-ge1d6bc0 2019-02-13 (835) 245MB -
    installed: 3.0.6 (770) 212MB -

Thanks for your reply, and valued help


#6

Hi zyga

output from ls -ld /etc/nsswitch.conf
-rw-r--r-- 1 root root 507 Jul 23 2015 /etc/nsswitch.conf

Thanks for your reply, and valued help


#7

Thank you for the previous output. Can you do some more debugging please:

journalctl | grep DENIED

dmesg | grep DENIED

sudo cat /sys/kernel/security/apparmor/profiles


#8

Thanks zyga. Runningjournalctl | grep DENIED returned “Unprivileged users cannot access messages, unless persistent log storage is enabled. Users in the ‘systemd-journal’ group may always access messages.” So I ran it as sudo and the output was nothing.

I ran dmesg | grep DENIED and that also returned nothing.

Output from sudo cat /sys/kernel/security/apparmor/profiles:

snap.vlc.vlc (enforce)
snap.core.hook.configure (enforce)
snap-update-ns.vlc (enforce)
snap-update-ns.core (enforce)
/snap/core/6350/usr/lib/snapd/snap-confine (enforce)
/snap/core/6350/usr/lib/snapd/snap-confine//mount-namespace-capture-helper (enforce)
/usr/lib/snapd/snap-confine (enforce)
/usr/lib/snapd/snap-confine//mount-namespace-capture-helper (enforce)
/usr/sbin/tcpdump (enforce)
/usr/sbin/cups-browsed (enforce)
/usr/bin/evince-thumbnailer (enforce)
/usr/bin/evince-thumbnailer//sanitized_helper (enforce)
/usr/bin/evince-previewer (enforce)
/usr/bin/evince-previewer//sanitized_helper (enforce)
/usr/bin/evince (enforce)
/usr/bin/evince//sanitized_helper (enforce)
/usr/sbin/cupsd (enforce)
/usr/lib/cups/backend/cups-pdf (enforce)
/usr/lib/connman/scripts/dhclient-script (enforce)
/usr/lib/NetworkManager/nm-dhcp-client.action (enforce)
/sbin/dhclient (enforce)

Thanks again