Snap-store dont display text

I’m new to Lunix and would like getting help to solve a problem with the snap-store.
Texts are not being displayed …

store

$ snap version
    snap     2.39.3-3
    snapd    2.39.3-3
    series   16
    manjaro  -
    kernel   4.19.56-1-MANJARO

$ snap info core
    name:      core
    summary:   snapd runtime environment
    publisher: Canonical✓
    contact:   snaps@canonical.com
    license:   unset
    description: |
      The core runtime environment for snapd
    type:         core
    snap-id:      99T7MUlRhtI3U0QFgl5mXXESAiSwt776
    tracking:     stable
    refresh-date: today at 18:39 -03
    channels:
      stable:    16-2.39.3                    2019-06-27 (7270) 92MB -
      candidate: 16-2.39.3                    2019-06-25 (7270) 92MB -
      beta:      16-2.40~pre1                 2019-07-02 (7343) 92MB -
      edge:      16-2.40~pre1+git1391.d09d311 2019-07-09 (7371) 92MB -
    installed:   16-2.39.3                               (7270) 92MB core

I researched here in the forum, but I did not find a related topic.

Thanks in advance for the help!

It looks like your system is missing a font. What localization are you using? Is it English, or something else?

my system is configured to pt-BR

It “sounds like” you are missing the language pack for that local. I am not familiar with Manjaro, so I am not entirely sure how to fix that specific issue. For example, there was an article for adding support to Ubuntu.

What I would do is check in with the Manjaro forums and see how to add pt-BR support. My gut feeling is that this is not a snap specific issue.

I looked up the subject you suggested and found a page with information on how to properly set the display language.

https://wiki.manjaro.org/index.php?title=Locale

But that still was not enough to solve the problem.
I’ll continue to use snap through the command line …

Anyway, thank you for all your help @bashfulrobot !!

Is this the snap-store snap?

Yes. I have installed It by command

$ sudo snap install snap-store

Tagging @kenvandine and @robert.ancell so they are aware of this issue.

Sorry I was not more help! I see a few additional responses here; so you are likely in good hands! :+1:

1 Like

@wrcall I asked @popey to try the snap-store on Manjaro and he said it looked fine for him. Can you please try some other snaps to see if you see something similar? Perhaps try the gnome-calculator snap and report if you see a similar issue.

Hi @wrcall, have you solved this problem then? I have the same problem on arch linux.

I think the problem is related to apparmor… @mborzecki , any idea?
The snaps I install with --classic can access fonts…

I posted some information I collected while debugging this problem in this topic:

The conclusions were that not all snaps are affected, but those that used gnome runtime content snap appeared to be.

Thank you @mborzecki …will follow the topic. Hope it get solved soon.

The issue was solved in Manjaro forum:

https://forum.manjaro.org/t/snap-store-font-issue-everything-is-a-rectangle-screenshot/105932/5

It seems like the issue is related to fontconfig update.

1 Like

The forum no longer is there, so is there a way to have the solution set here please?
Thanx!

any info on how to solve this issue? im new to all of this

Try giving these commands and running your app:
$ sudo rm -f /var/cache/fontconfig/*
$ rm -f ~/.cache/fontconfig/*

It worked for me to get past an error while trying to run CloudCompare

Goodluck!