Snap store broken?

Installation of snap-store on Ubuntu or Manjaro appears to be broken.

[seb@minimonster 10:58:11 ~]$ snap-store
/snap/snap-store/518/usr/bin/snap-store: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child
[seb@minimonster 10:58:28 ~]$ 

Embarrassing for Canonical. I hope they fix it soon.

Seb

This looks to be a bug introduced by the recent gnome-3-34-1804 update. You should be able to fix this temporarily by running the following in the terminal:

sudo snap revert gnome-3-34-1804

We’ll need to do a bit more investigation into what happened here, and put a proper fix out.

Upon further investigation, the problem appears to be that the snap-store snap bundles a copy of libatk, which shadows the copy from the GNOME platform snap.

That copy happened to be compatible with the GTK from the previous version of the platform snap, but is missing a symbol needed by the new version. So we should be able to fix this by releasing a new version of snap-store that omits the libatk copy.

1 Like

hey guys i am new so i am having the same problem but when i did run the command i did “snap run snap-store” and it did not open it and it did this “Warning: Schema “org.gnome.system.locale” has path “/system/locale/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy” has path “/system/proxy/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.http” has path “/system/proxy/http/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.https” has path “/system/proxy/https/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.ftp” has path “/system/proxy/ftp/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. Warning: Schema “org.gnome.system.proxy.socks” has path “/system/proxy/socks/”. Paths starting with “/apps/”, “/desktop/” or “/system/” are deprecated. /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child ERROR: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 exited abnormally with status 127 /snap/snap-store/518/usr/bin/snap-store: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child”

Hi, I moved your post to more appropriate topic. This a known problem in the snap-store snap. Please see earlier replies from @jamesh in the current topic.

FWIW, there’s a corresponding bug report: https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1931380

2 Likes

A fix for this is in the beta channel AIUI, you can refresh to try out the fix with:

snap refresh snap-store --beta --ignore-running

You can omit the --ignore-running if you do not have refresh app awareness enabled.

2 Likes

This was published to stable earlier today, but it’s a progressive release so will roll out over 24 hours.

3 Likes

How could this happen?

If this can happen than there is a serious design bug and an implementation bug in your snap system.
I thought a new Gtk would just pull in all dependent libraries?

Just fixing this bug is not a solution but a hack.

Where is the integration test that is at least starting the final build snap. We need to add testing capabilities into the build snaps. So Apps can run at least basic tests when invoked with “–run-tests” developer or not.

Hi Everyone,
Is the snap-store armhf stable release also supposed to be updated to version 3.38.0-63 ?
So far it has not been updated, although more than 24h passed since the release of version 3.38.0-63.