Snap on Debian 9.4 and Firefox installation - Fonts issue

I have installed stap on Debian 9.4 as stated in the manual
$ sudo apt install snapd

Then I have installed Firefox 61
$ sudo snap install firefox

When i run firefox
$ snap run firefox

I get the errors:
/snap/firefox/103/bin/desktop-launch: line 174: /home/myuser/snap/firefox/common/.config/user-dirs.dirs: No such file or directory
cp: cannot create regular file ‘/home/myuser/snap/firefox/common/.config/’: Not a directory
/snap/firefox/103/bin/desktop-launch: line 177: /home/myuser/snap/firefox/common/.config/user-dirs.dirs.md5sum: No such file or directory
/snap/firefox/103/bin/desktop-launch: line 177: /home/myuser/snap/firefox/common/.config/user-dirs.locale.md5sum: No such file or directory

The firefox application (all menues) is using some monotyped font like courier new or simiiar

I have tried to change the font in firefox settings but it has no impact. Beside that the font dropdown list is showing all my system fonts names but all have this monotyped face and look

Not sure if this is a firefox snap issue / snapd issue on debian or a problem with snap privileges to my home folders

1 Like

The errors you’re seeing should be harmless.

I installed debian stable (9.5) in a VM and installed the firefox snap, and I’m not seeing what you’re describing: the font for the UI doesn’t look great (not antialiased maybe?), but it’s not monospace. See screenshot:

Can you share a screenshot of how the UI looks like for you?


This is not an antialiased font issue. Please find one screenshot bellow (I am a new user and can attach only one per post but it presents the issue)

Best Regards,


I also found the snap had trouble rendering fonts correctly. Below you can see, on the left, Firefox 60.2.0esr running as a native package in Debian stretch and on the right, Firefox 62.0 from the snap. The versions are different but the problem was ocurring before the 62 snap upgrade.

We see better the effects when the image is viewed in full screen.

Also, this seems to be a bug in Firefox itself that makes it fail to use the proper fallback font when certain metrics are used.

Zooming the page in and out can trigger the bug, for example, although it’s not clear to me why this would happen in the snap and not outside.