Snap is broken: cannot perform operation: mount --bind /snap/core/current//etc/alternatives


#1

Dear all,

I am maintaining a server with Rocket.Chat on a Debian (jessie) Xen container for over a year now. Everything went fine until today, when I did the usual apt-get update and apt-get ugrade on the system. After the update the Rocket.Chat was not reachable. I also have another server, running almost the same setup (same system and software versions and the very same Xen setup) and I had no problems there.

A frequent error message I find in the corresponding log files is:
cannot perform operation: mount --bind /snap/core/current//etc/alternatives /tmp/snap.rootfs_23qAba/etc/alternatives: No such file or directory

After trying all sorts of suggestions from several forums, I tried to start over and created a completely fresh Debian installation on a new disk (vg) and restored the backup from the day before. However, I got the same behaviour. I tried the oldest backup and no luck, the chat server components refuse to start and print that mount error message. It seems that this error existed before my oldest backup and some process during apt-get revealed it. No idea?!

Long story short, it seems that the snap installation is completely broken and I am really puzzled where to start to fix it, so I ask you experts and hope that someone can point me into the right direction. My biggest issue is, that there is no direct backup of the chat database (I have only full system backups, which obviously do not help), and I can only do a backup when the mongodb instance is running, which however also lives in the snap environment and won’t start.

Here you can see that not even a small program like ponysay works:

> snap install ponysay
ponysay 3.0.3 from 'adasiko256' installed
> ponysay
cannot perform operation: mount --bind /snap/core/current//etc/alternatives /tmp/snap.rootfs_23qAba/etc/alternatives: No such file or directory