Snap is broken after broken update to Ubuntu 19.04

I upgraded to 19.04 few weeks ago, however the screen froze mid-upgrade (assuming due to graphics driver glitch, I use a GTX 1070 card, yea I still need to figure out why none of the official drivers work with the card, but that’s for next time). I restarted because the screen practically stopped responding, and followed something like this

There are still a lot of random broken things, but I reseted my home directory and started everything from scratch so everything seems to work fine. Except the software center is now complaining SSL handshake error and some error regarding snap store CA unknown.

I ran

sudo dpkg-reconfigure -p critical ca-certificates

but that doesn’t seem to change anything. I still get errors whenever I run snap commands

jeffrey04@NOBITA-UBUNTU:~$ snap refresh core
error: cannot refresh "core": cannot refresh snap-declaration for "gnome-logs":
   x509: certificate signed by unknown authority

There’s nothing much I can find about the error message, and the only place I found that says don’t try to MITM the CA which is not helpful. What should I do?