Snap install acestreamplayer


#21

The file is provided by the bluez package, I would suggest re-installing it for the sake of the regular desktop system’s dependency requirements.


#22

OK - I’ve done that and now I see the rule in /lib/udev/rules.d, but the hid2hci keeps spamming the output.


#23

Is it still the case after running sudo udevadm control --reload?


#24

Yes, the output keeps getting spammed by hid2hci.


#25

Try running sudo dpkg-divert --local --rename --divert /lib/udev/rules.d/97-hid2hci.rules.disabled --add /lib/udev/rules.d/97-hid2hci.rules and sudo udevadm control --reload in a terminal, and verify if the spamming is still happening


#26

Yeah… I ran your commands but spamming is still there.

sudo dpkg-divert --local --rename --divert /lib/udev/rules.d/97-hid2hci.rules.disabled --add /lib/udev/rules.d/97-hid2hci.rules

Leaving ‘local diversion of /lib/udev/rules.d/97-hid2hci.rules to /lib/udev/rules.d/97-hid2hci.rules.disabled’


#27

I have no idea how to solve this problem right now, you may try to clear the /lib/udev/rules.d/97-hid2hci.rules{.disabled} file’s content and run sudo udevadm control --reload-rules and sudo udevadm trigger or reboot but the modification won’t survive after the next bluez package upgrade.


#28

This is something very stubborn, I disabled bluetooth in the BIOS, but hid2hci keeps bugging.


#29

This seems to be related to:

https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1759836

(seemingly comment 70 has a workaround)


#30

I tried that before and it didn’t work for me, but is possible that it was because i didn’t reboot the system - I will try it again.

Thanks


#31

I will try that comment 70 again, so now I have 97-hid2hci-.rules.disabled - how do I formally enable that rule again?


#32

It depends on what you’ve previously done with the file.

For dpkg-divert check out the --remove option of the command, the sudo dpkg-divert --remove /lib/udev/rules.d/97-hid2hci.rules should do the work.