Snap Icons: Is the firefox .desktop file missing StartupWMClass?

I have the mozilla stable version installed using the mozilla binary method, and snap for the beta channel. The icon is broken, both in the menu entry and in the panel. That is, there is no icon in menu, and the generic cog icon in the panel.

This is on 22.04 But I have the same problem in 23.10 and in a VM 22.04. That is, I can reproduce this every time.

I did snap remove firefox

to uninstall, but this file



So I remove it manually, and reinstall.

The desktop file for this is now:


It is called Firefox Web Browser in the gnome launcher, and it has an icon. But after launching, it still uses the generic cog icon in the panel. The context menu from this icon has no actions, except to Quit. If I create a second window, both are associated with this icon, which is good.

In the Gnome launcher, if you search for an app and if that app is running, the Gnome launcher indicates it with a dot. However, while this works for the mozilla binary, the icon of Firefox Web Browser does not show a dot, even though I have two windows from it open.



From chatgpt help, I see this:

Addthis this line to the .destkop file, near the top, fixed it:


this is such an easy thing to fix (I’ve just manually fixed it on a new Ubuntu 23.10 install). How do we file bugs against the firefox snap?


To me, the situation is very confusing. I filed a launchpad bug, but it is against a .deb transitional package. The bug is for the snap package. I do not have confidence that reporting a bug against the .deb is helpful.

Where do I find the packaging for snap? It it a “mozilla” product, with no involvement of debian? I filed a bug there too, but wow this is hard to work out. imported to lp:~mozilla-snaps/firefox-snap/+git/firefox-snap : Git : Code : firefox snap

1 Like

The Firefox snap is fully managed by Mozilla themselves. Canonical is not involved and Debian is neither. This is their bugtracker:

Not trying to be contradictory, but that doesn’t seem to be strictly true. I agree the snap is “published by Mozilla” (as the Github repo puts it) and the account listed at is Mozilla. But most committers to the Firefox snap repo are Canonical employees, compared with one Mozilla I see, and the repo is under Canonical’s github account, not Mozilla’s.

Ok, seems like I might be wrong, thanks for the correction!

Mozilla’s bugzilla is the correct place to report bugs for the Firefox snap. We collaborate with mozilla on the maintenance, but the Mozilla release team handles publishing.

1 Like

I already reported it there just in case. Counting my snapcraft report, I have reported it three times now. The launchpad one got confirmed as someone found it in google searching for the same problem.

At, someone tagged it as being a gtk widget bug. I am not convinced that is correct.