Snap doesn't work in networked environment (Ubuntu 18.04 Server+Client)

I did install Ubuntu Bionic 18.04, it comes with snapd version 2.32. Snap still doesn’t work correctly with home folders mounted via NFS. Where is the NFS support? I’m even unable to use basic applications like System monitor:

kernel: nfs: RPC call returned error 13
kernel: audit: type=1400 audit(1526303580.147:309): apparmor=“DENIED” operation=“sendmsg” profile="/snap/core/4571/usr/lib/snapd/snap-confine" pid=32548 comm=“snap-confine” laddr= lport=1003 faddr= fport=2049 family=“inet” sock_type=“stream” protocol=6 requested_mask=“send” denied_mask=“send”
gnome-system-monitor_gnome-system-monitor.desktop[31416]: cannot change current working directory to the original directory: Permission denied
cannot create user data directory: /home/michalmaria/snap/gnome-system-monitor/39: Stale file handle

Upgraded to snapd 2.32.8+18.04. Still doesn’t work…

Upgraded to snapd 2.32.9+18.04. Still doesn’t work…

Doesn’t work for me too.

The problem lies with autofs and current AppArmor configuration, which does not take autofs into account. Bug for this issue opened here: