Snap cannot access service running in Docker

Hi,

I use the snap package of Beekeeper and Docker on my Ubuntu 20.04.1 LTS desktop. I run PostgreSQL with its ports published on the host machine and try to connect to it through Beekeeper. However the connection cannot be established.

I tried the AppImage package of Beekeeper and it connected to the DB just fine. Is this a permission issue? I can’t see any relevant messages from snappy-debug output.

Are you saying that you have both Beekeeper and Docker both installed as snaps?

so PostreSQL is running as a docker container?

Yes, PostgreSQL is running as a Docker container with its port (5432) bound to the host machine. Both Beekeeper and Docker are snaps.

What snap interfaces are connected for beekeeper? snap connections beekeeper-studio

$ snap connections beekeeper-studio                                                                                                                                                                                                                                                                                                                  
Interface                 Plug                              Slot                             Notes
audio-playback            beekeeper-studio:audio-playback   :audio-playback                  -
browser-support           beekeeper-studio:browser-support  :browser-support                 -
content[gnome-3-28-1804]  beekeeper-studio:gnome-3-28-1804  gnome-3-28-1804:gnome-3-28-1804  -
content[gtk-3-themes]     beekeeper-studio:gtk-3-themes     gtk-common-themes:gtk-3-themes   -
content[icon-themes]      beekeeper-studio:icon-themes      gtk-common-themes:icon-themes    -
content[sound-themes]     beekeeper-studio:sound-themes     gtk-common-themes:sound-themes   -
desktop                   beekeeper-studio:desktop          :desktop                         -
desktop-legacy            beekeeper-studio:desktop-legacy   :desktop-legacy                  -
gsettings                 beekeeper-studio:gsettings        :gsettings                       -
home                      beekeeper-studio:home             :home                            -
mount-observe             beekeeper-studio:mount-observe    :mount-observe                   manual
network                   beekeeper-studio:network          :network                         -
opengl                    beekeeper-studio:opengl           :opengl                          -
pulseaudio                beekeeper-studio:pulseaudio       :pulseaudio                      manual
removable-media           beekeeper-studio:removable-media  :removable-media                 manual
ssh-keys                  beekeeper-studio:ssh-keys         -                                -
unity7                    beekeeper-studio:unity7           :unity7                          -
wayland                   beekeeper-studio:wayland          :wayland                         -
x11                       beekeeper-studio:x11              :x11                             -