Snap apps not opening after update


sanp info:
snap 2.51.7-1
snapd 2.51.7-1
series 16
kali 2021.3
kernel 5.10.0-kali9-amd64
system info:
Linux kali 5.10.0-kali9-amd64 #1 SMP Debian 5.10.46-4kali1 (2021-08-09) x86_64 GNU/Linux

After system updates the latest updated apps are not opening giving the error WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement cannot change profile for the next exec call: No such file or directory snap-update-ns failed with code 1

1 Like

I am having a similar problem with the exact same release of Kali Linux and snapd version. Except, I do not receive the same error message as you. I only receive the following:

cannot change profile for the next exec call: No such file or directory

Which leads me to believe ‘cgroup v2 is not fully supported…’, is not really the problem at hand. The ‘cannot change profile…’ is the problem. AND it seems that I am just as in the dark as you are at the moment.

I wrote a script that works for me . https://gitlab.com/Aviksaikat/snap_fix_kali_debian try this see if this solves your problem until there is an official solution. My best guess the latest kali kernel is not compatible with this version of snap yet

1 Like

Just FYI,
My original issue is with my IDE, phpstorm, but I tried opening another snap app and received the same error message as you.

AND yes, your script worked for me as well.

1 Like

This comes from AppArmor, snap-confine which is executed when starting the snap is unable to switch the apparmor profile to one generated for a snap. Usually this means you may need to restart the apparmor.service (or enable it). On some distributions you may need to start and enable snapd.apparmor.service, which you can do by running systemctl enable --now snapd.apparmor.service.

Correction, the script did not work for my system, and I am still cut off from my development environment. :cry:

Well, I’ll be a monkey’s uncle… Like a bolt of pure, uninhibited awesomeness… I can’t believe that it was such a simple solution. That service should have been enabled from the start. Great Jehoshaphat!!!

For the record, which distribution do you use?