Slack snap - window has no icon


#42

This continues to be a problem because Slack does not provide an icon using the NET_WM_ICON property.


#43

Fedora 29, It worked for me


#44

Linux Mint 19.1, Cinnamon desktop, still has no icon.
I already tried to add StartupWMClass=Slack to the desktop file.


#45

I am on Ubuntu 18.10, running XFCE. My indicator icon was showing the Slacktothorpe properly, but the window list displayed the default fallback icon.

As a workaround, Paul Evans’ xseticon may be used to change the icon of an already-running Slack instance. This seems to work even after closing the window and reopening it from the tray/indicator.

  1. Clone https://github.com/xeyownt/xseticon
  2. Install dependencies
    sudo apt install libxmu-headers libgd-dev libxmu-dev
    
  3. Do the make dance
    make
    
  4. Install the binary somewhere on your $PATH
    sudo cp xseticon /usr/local/bin
    
  5. With the Slack window visible, execute the following, which will provide crosshairs to select the Slack window
    xseticon /snap/slack/9/usr/share/pixmaps/slack.png
    
  6. bada bing, bada boom

#46

Hi,
I have the same problem with the last version:
Slack: 3.3.4
Snap: 2.36.3-1
Xfce4: 4.12


#47

Linux Mint 19.1, Cinnamon desktop, still has no icon.
StartupWMClass=Slack didn’t help
Is there a workaround?


#48

I was having this issue on Debian 9 (Stretch), adding the StartupWMClass=Slack line to the .desktop file solved it for me.


#49

Can confirm that the desktop file mod fixes it in ubuntu 18.10 as well.


#50

It still isn’t setting an EWMH icon. However, as of 3.4.0, Slack sets _NET_WM_WINDOW_TYPE = _NET_WM_WINDOW_TYPE_MAIN. This causes Slack to be left out of the alt-tab menu. _NET_WM_WINDOW_TYPE_MAIN is not defined in the EWMH spec and has no results on a Google search.

https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/1827302


#51

Note that the xseticon utility is now packaged as a snap:


#52

Worked for me too! Thanks. It should be somehow added to the app because any update removes this change.


#53

Linux Mint 19 with Cinnamon desktop, still has no icon. StartupWMClass=Slack didn’t help me too. :frowning_face:


#54

Linux Mint still misses the tray icon, but only with the snap version.


#56

Same issue on Solus Budgie. Task icon is visible, but no tray icon. If I close the Slack window (close to tray enabled in Slack settings), then there’s no way to restore it other than relaunching Slack.