Signal Desktop losing all conversations and account link after update

Hello there, with the latest update from v5.16.0 to v5.17.2 all conversations in Signal Desktop were lost and a relink forced.
The same happened before with the update from v5.6.1 to v5.7.0 and was fixed with v5.12.2.

As I did after the release of v5.7.0, I have reverted back to the last working snap v5.16.0 and am planning to continue using this version until a new update will work. The command is:
sudo snap revert signal-desktop --revision 372

I tried to file a GitHub issue for Signal Desktop before, but handling the issue was rejected because it might be a problem with the installation rather than Signal itself, so I understood.
Now I do not really know what to do, except wait and hope for the next update not to fail.

i have moved your post to the snapcrafters category, since they seem to own this snap … (and are actually testing a new release in another thread currently)

1 Like

This is a known issue with Snapd. It happens because Signal gets updated while it is still running. There is an experimental feature to fix this. Run the following in your terminal:

snap set core experimental.refresh-app-awareness=true

This enables the experimental feature which ensures signal doesn’t get updated while snapd is running.

Issue in our bugtracker:
more info about the experimental feature:

1 Like

Hello, thanks for replying but I am sure, this was not the case! I am already using the refresh-app-awareness option. While this last update was performed (automatically a few seconds after reboot), Signal Desktop was not active.

(Too often I experienced a malfunctioning Chromium browser after it was updated while I was using it, so I turned on the option a long time ago.)

Can you create an issue on our bugtracker?

I am happy to report, the problem is solved with version 5.22.0 (Revision 377)