Segmentation Fault running curl

We are consistently getting a segmentation fault running curl when trying to build our snap.

This is the line of code that fails:


Public CI logs can be seen here:

Hi, sorry for the inconvenience.
Do you mind confirming if using snapcore/snapcraft:candidate fixes the issue? This is probably related to PSA: classic confinement and core snapcraft issue

I’m not sure I can say I figured it out, but I fixed it.

The PR to fix the issue is here:

Two major changes… We started build the docker container ourselves as the one by snapcore doesn’t seem to work.

Second, I declared base and fixed some other warning snapcraft was giving

I tried edge and it did not fix the issue.

Use of base: core there is strange, I guess the test is done by just unsquashing per ?

Is there a way to retrieve what was built? I see but it does not tell me much about where things are published.

Additionally, anything related to core18 should not be needed,

Last, if I propose a PR, as an external contributor, does the CI test run and would I be able to retrieve the built snaps?

Yes, the agents are containers so we only unsquash to test.

Making the artifacts available was not a feature when I built the CI system. I have a PR to make it actually work. .

The changes related to core18 are commented out.

If you base your changes on PR#25 above, or if it is merged, you should be able to retrieve the built artifacts.

1 Like