Segmentation fault in python snap

I noticed an issue with a python snap (in this case ubuntu-make).
On a fresh ubuntu budgie install I tried installing the ubuntu-make snap and run it normally,
but there seems to be an issue, because it fails with a Segmentation fault.
It was running properly in previous revisions on 17.04.
The upstream master for ubuntu-make doesn’t have any issue running properly

I’m running:
snapd version 2.27.6+17.10
ubuntu-budgie 17.10 beta

@mvo, @ogra
I’m one of the maintainers for umake itself and the snap.
I tested older versions but they’re failing as well.
The issue seems to me to be related to any updates in snapd for 17.10,
since on older releases of ubuntu the program works without any problem.
Is there a way to debug this properly and see what’s going on?
Running directly from the git branch I can’t see any issue.

there ist a known issue with running classic snaps on non-xenial systems… it ist being worked on:

Thanks. I did read that thread a few days ago, but I thought the issue was different in this case, since the snap worked in other non xenial (mainly zesty) systems. I’ll follow that now, and see if the case in question is related. Thanks for the reply! :slight_smile:

@mvo Can I ask if you ended up looking at the ubuntu-make snap?
I tried changing it like the snapcraft snap, adding python and apt as parts.
That didn’t change much…
The only change that makes it work in 17.10 is to remove the LD_LIBRARY_PATH export.