'restart-delay' was unexpected

Hi all,

currently i’m facing a problem with the attribute ‘restart-delay’ of my snap service.
My yaml file looks something like:

type: app

grade: devel                                                                                    # must be 'stable' to release into candidate/stable channels
confinement: strict                                                                             # reduced file access to selected areas, reduced

    command: launch.sh
    plugs: [network, network-bind, process-control]                                             # extend network rights, needed for Codesys access (restriction caused by "confinement: strict")
    restart-condition: always
    restart-delay: 5s
    daemon: simple                                                                              # run from boot

On my system it is giving me following error when building snapcraft:

Issues while validating snapcraft.yaml: The 'apps/uaserver' property does not match the required schema: Additional properties are not allowed ('restart-delay' was unexpected)
Function call "snapcraft" failed!

I have updated to newst snapd:
snap 2.44.1+git643.g1dd3573
snapd 2.44.1+git643.g1dd3573
series 16
ubuntu 18.04
kernel 4.15.18-linuxkit

I tried to build it on an other system with same snap version and it worked.
Then i tried with passthrough for restart-delay and it was working also.

Do you have any ideas?
Thanks for your response.

what is snapcraft --version on the system spilling the error (note the error comes from snapcraft not from snapd or snap)

snapcraft, version ‘3.6’

snapcraft 3.6 is old. You probably should update to the latest in stable:

snap refresh --stable snapcraft

Ok i got this. It works fine with newer snapcraft.
Thank you guys!