Resetting an Ubuntu user snap profile

I got some issues with two snaps on Ubuntu 18.04 LTS when using my usual user account: Skype (–classic) and Gitkraken.
Launching skype leads to a logout!
Gitkraken starts to lauch but fails to display the usual GUI

I finally created a second user account with the same privileges on my system. With this new account, everything’s fine.

So I suspect my usual account is somehow corrupted. I tried to delete the span folder located in my home but no change.
Is there a way to reset my snap profile?

The solution I found was deleting and recreating the user account.

However, I guess there must be a more elegant solution.

Snaps store their user configuration data in the ~/snap folder. If you wanted to wipe all user configuration for the skype snap, removing the ~/snap/skype folder should do the trick.

Thanks for this answer
Actually I already tried to remove this folder to get a fix, with no result. I also tried apt-get purge et (re-)install of the snapd.
Eventually the solution that worked was deleting and (re-)creating the user without touching the home folder. So I guess there must something else somewhere that could explain this behaviour, may be access right on some system libraries.