Requesting to join snapcrafters: branch-diff

Hello @evan, @popey, and @Wimpress,

I would like my snap of branch-diff, a tool to list print the commits on one git branch that are not on another using loose comparison, to be added to the snapcrafters group.

You can install it by entering the command sudo snap install branch-diff

My github is LaughingLove


I’m afraid I can’t get this snap to do a single thing, no output at all:

$ branch-diff -h
$ branch-diff --help
$ branch-diff 
$ branch-diff master devel

It also has no interfaces defined, so it can’t actually access any repositories in my home directory or anything. I suggest adding at least that interface. How have you tested this snap so far?

EDIT: I realize your actual problem now. The snap couldn’t access the network so I added the [network] plug and it couldn’t access git so I changed the confinment from strict to classic. I will try to request to allow my snap to have classic confinement. added the home plug and embedded a copy of git. You can see the commit here.

If you want to install the updated version you can update your snap or remove the snap and do sudo snap install branch-diff again.

Hey! I’m so sorry you’re having difficulties with the snap! Let me touch on the points you stated.

I went back and tested it and I too, had some difficulties. However I solved the problem by doing some steps:

  1. Do a git checkout [branch] to the branch you want to compare.
  2. Do branch-diff [other-branch] [current-branch]

In your case it would be branch-diff master devel (After you checkout to dev)

You should see output along the lines of this.

I am very sorry about this too. I also tried branch-diff --help but to no result. However, because I am not the original creator of the application I cannot directly fix it. The most I can do is create an issue here. (Which I will do shortly)

To see the full list of available paramaters, please see their

Much better! Now running branch-diff --help actually SAYS it doesn’t work instead of doing literally nothing. Things seem to be working now.

Hey @jokinglove, I’ve sent you a few pull requests. Please review them:

1 Like