Request for classic confinement, whatsdesk


#1

I’d like to request classic confinement for whatsdesk snap which is built from https://gitlab.com/zerkc/whatsdesk

this is for create settings and read plugins created in the home user


#2

Can you explain more why you cannot run under strict confinement?

A few observations and thoughts:

  • The home plug will allow files sent over whatsapp to be saved to the user’s home folder.
  • I would suspect that the plugins you mention could be installed into the snap’s writeable locations.
  • Settings for an electron app can be saved to the snap’s writeable locations.

#3

Hi,
The installation of the app is by snap and by .deb the idea is to maintain the same functionality and a compatibility between the 2 installations, for this reason I need to read and write the home folder of the user, and the strict mode does not allow me to do this


#4

To re-iterate what @daniel said, what about the home plug?


#5

Bear in mind inside your application when you use file dialogs, it may default you to somewhere inside the snap view of the world, typically in $USER/snap/(snapname)/current. However you can still browse to the ‘real’ home directory of the user with the home plug specified.


#6

This is the error that I have, if I am missing some configuration I would appreciate it if they could help me


#7

Aha! The home plug explicitly denies access to “dot folders” to prevent it accessing files such as your ssh or gpg keys.

The application can store data in $SNAP_USER_DATA or $SNAP_USER_COMMON, which will point at places like /home/(user)/snap/(snapname)/current and /home/(user)/snap/(snapname)/common respectively.

You can, in the snapcraft.yaml coerce the application to see $HOME as one of those with an environment line such as:-

apps:
  whatsdesk:
    command: bin/whatsdesk  # or whatever it should be
    environment:
      "HOME": "$SNAP_USER_DATA"

Which may help.


#8

Thank you so much i really appreciate your help


#9

Based on the comments in this forum, I’m marking the topic as solved without granting classic. If this is in error, please comment here. Thanks!