Request classic confinement review for share


#1

Share needs classic mode because it needs to copy data to the user clipboards. This is done by executing xclip or xsel

https://dashboard.snapcraft.io/snaps/share/revisions/18/


#2

Are you sure you need classic? I recently made a snap of another command line application which manipulates the clipboard, and it didn’t need classic to function. I only specified the x11 plug and staged xsel which worked for me. What errors are you seeing in your application when you do not use classic?


#3

hi thanks for the info. can you give me an config example?

I tried:

apps:                                               
  share:                                            
    plugs: ["home", "network", "x11"]               
parts:                                              
  share:                                            
    stage-packages:                                 
      - xsel

#4

Sure, here’s an example. https://github.com/popey/yank/blob/add-snapcraft/snap/snapcraft.yaml


#5

this doesn’t work for me. “parts” is not available in snap.yaml
I use goreleaser which uses snapcraft pack


#6

I still need classicmode because i cannot build-in xsel


#7

I understand @Igor has been discussing this missing functionality from goreleaser with the maintainer, so there should be a fix coming soon.
Sadly we can’t grant classic in this case as it’s not warranted.


#8

Can you describe what goreleaser should do? maybe i can make an PR.

currently it creats a snap.yml


#9

@popey is right, classic is not needed; only need to plugs x11.