Removing progress bars from Travis logs

Looking at the raw logs from Travis, we have quite a few occurrences of this:

Cloning into 'snapcore/snapd'...
remote: Counting objects: 7956, done.e[K
remote: Compressing objects:   0% (1/3473)   e[K
remote: Compressing objects:   1% (35/3473)   e[K
remote: Compressing objects: 100% (3473/3473), done.e[K
Receiving objects:   0% (1/7956)   
Receiving objects:   1% (80/7956)   
Receiving objects:   2% (160/7956)   
Receiving objects: 100% (7956/7956), 2.71 MiB | 0 bytes/s, done.
Resolving deltas:   0% (0/5155)   
Resolving deltas:  10% (518/5155)   
Resolving deltas: 100% (5155/5155)   
Resolving deltas: 100% (5155/5155), done.

To a total of hundreds of lines which not only take up space but contribute towards the max that Travis is willing to display properly formatted.

Should be easy to avoid that with command line flags or environment variables.

cc @fgimenez

Why not tty detection like apt does and we try to do in snapcraft. There’s also the convention of TERM=dumb.

@sergiusens Note that this is coming from external tools used during the test setup.

Heh, looks like git, should of spotted that.

git clone --quiet might do the trick then.

@niemeyer this is how it looks like after adding the quiet option that @sergiusens mentioned seems to work great thanks! This is the PR for passing that option through .travis.yml

1 Like

And the PR is in! Thanks @fgimenez